Bug 71321 - Can't scroll down in Calc and Writer on Mac osx
Summary: Can't scroll down in Calc and Writer on Mac osx
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Mac OS X (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 71348 (view as bug list)
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-11-06 19:00 UTC by Thomas van der Meulen
Modified: 2015-12-15 22:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas van der Meulen 2013-11-06 19:00:16 UTC
Problem description: in Version: 4.2.0.0.alpha1
Build ID: c2b9ad37f8a8de9c7dbdd76c86aecf6388107056
you can not scroll down in Writer or Calc, you can scroll up but not down

Steps to reproduce:
1. open Writer or Calc and try to scroll down
2. ....
3. ....

Current behavior: nothing happens

Expected behavior: scroll down

              
Version: 4.2.0.0.alpha1
Build ID: c2b9ad37f8a8de9c7dbdd76c86aecf6388107056
Operating System: Mac OS X
Version: 4.2.0.0.alpha0+ Master
Last worked in: 4.1.3.2 rc
Comment 1 Thomas van der Meulen 2013-11-06 19:02:18 UTC
os: mac osx 10.9
Comment 2 Jorendc 2013-11-06 21:34:50 UTC
Dangit, I can reproduce this behavior, tested using Mac OSX 10.9 with LibreOffice Version: 4.2.0.0.alpha1
Build ID: 496e2be9dd6eb96d120d412760422eaa904b7f71

Going to nominate as MAB4.2
Comment 3 Jorendc 2013-11-06 21:37:21 UTC
side note: The only way to scroll down is to drag the scrollbar down. Scrolling up isn't affected.
Comment 4 retired 2013-11-07 10:45:15 UTC
Thomas, Joren: where do you find those alpha builds? You are all building them yourself?
Comment 5 Jorendc 2013-11-07 11:46:16 UTC
(In reply to comment #4)
> Thomas, Joren: where do you find those alpha builds? You are all building
> them yourself?

http://dev-builds.libreoffice.org/pre-releases/mac/
:)
Comment 6 Stephan Bergmann 2013-11-07 14:13:07 UTC
#libreoffice-dev:
> Nov 07 09:50:36 <tml> sberg: most likely 4e7495ac2cb6b015ad492def45fd24f4ba0f54f8 causes the scrolling problem
> Nov 07 09:50:38 <IZBot> core - Fix for iOS scroll by pixels, and pinch to zoom - http://cgit.freedesktop.org/libreoffice/core/commit/?id=4e7495ac2cb6b015ad492def45fd24f4ba0f54f8
Comment 7 Jorendc 2013-11-07 15:51:43 UTC
*** Bug 71348 has been marked as a duplicate of this bug. ***
Comment 8 retired 2013-11-07 20:55:56 UTC
Raising to high. Is this isn’t high or even highest I don’t know what would be.
Comment 9 Jorendc 2013-11-10 15:38:34 UTC
The bot isn't auto-commenting on the bug when a commit is made related to this bug.
Thanks to Tor during the week-end: http://cgit.freedesktop.org/libreoffice/core/commit/?id=07032e5a6ef2fa42229e8bbf5219935beefa2447

Not tested yet.

Kind regards and thanks for your work related to OSX and other parts in LibreOffice Tor! Much appreciated :)

Kind regards,
Joren
Comment 10 retired 2013-11-15 09:44:55 UTC
Thanks to the OS X nightly back in working state I'm able to verify this fix (first nightly since the old nightly machine died :)

Tor, thanks so much this was a real road-blocker.

Setting to RESOLVED FIXED.
Comment 11 Robinson Tryon (qubit) 2015-12-15 22:17:33 UTC Comment hidden (obsolete)