Bug 71330 - TABLE: Libre office crashes many times when inserting a row to a table
Summary: TABLE: Libre office crashes many times when inserting a row to a table
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Linux (All)
: high blocker
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-07 02:53 UTC by Sreekanth
Modified: 2014-03-31 08:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sreekanth 2013-11-07 02:53:34 UTC
Problem description: 

I have prepared a test specification with lot of data. I have a table to enter each test case. Some times when I try to insert a new row, libre office crashes. Even the data in the table is lost. This is so irritating. With out this kind of basic thing not working, this is completely useless product.

Opensource community needs a product which can substitute MS Office and that's the reason Sun started this project. And now this has become a joke. Basic table functionality not working is acceptable at all.

Steps to reproduce:
1. Create a text document
2. Insert table into it
3. Add data to the table.
4. Now try to insert some more rows at different places.
5. Observe that the open office crashes
6. If you really out of your luck, even the data will be lost.

Current behavior:
1. Application crashes when a row is inserted. This is most common bug I see when I google.

Expected behavior:
1. The application shouldn't crash like this.

              
Operating System: Debian
Version: 4.1.2.3 release
Comment 1 m.a.riosv 2013-11-07 03:30:01 UTC
Hi Sreekanth, thanks for reporting.

Have you tried resetting the user profile?, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile.

If this not solve the issue, please can you attach a sample file.
Comment 2 Sreekanth 2013-11-07 05:02:31 UTC
Yes. I tried that. It didn't work for me
Comment 3 Sreekanth 2013-11-07 05:02:51 UTC
Are there any log files which I can upload here?
Comment 4 Sreekanth 2013-11-07 05:03:28 UTC
Is there a way data can be recovered. It actually destroyed a whole weeks effort just like that.
Comment 5 m.a.riosv 2013-11-07 22:47:48 UTC
Looking in LibreOffice backup or temporary folder if there are some recoverable file, to know the paths Menu/Tools/Options/LibreOffice/Paths.
Comment 6 Sreekanth 2013-11-08 06:02:36 UTC
Nothing there. An empty folder :(

sreekanth@spidy:~/.config/libreoffice/4/user/backup$ ls -al
total 8
drwxr-xr-x  2 sreekanth sreekanth 4096 Nov  7 14:53 .
drwxr-xr-x 13 sreekanth sreekanth 4096 Nov  8 11:31 ..
Comment 7 Joel Madero 2013-11-09 02:34:01 UTC
Unfortunately with the given information we can't do much. We need you to make a test document for us as:

2. Insert table into it
3. Add data to the table.


Are not enough for us to do anything - we might spend hours "adding data" and testing based on this and get nowhere. Please provide us with a test document that we can just insert rows and see a crash. Once you do so, mark the bug as UNCONFIRMED and we'll try to help
Comment 8 Sreekanth 2013-11-09 03:23:13 UTC
Hi Joel,

I completely agree with you. I could have given  you the same document  I was using. But its a private document. I will try to give you a document where I can reproduce. 

Here are some questions for the team.

1) Is there any specific requirement for Java version?
2) Is there any way I can enable logging?
3) When the office suite crashes, is there any crash dump that gets created?
4) I see a lot of people reporting the same issue in google. Were they resolved?
Comment 9 Joel Madero 2013-11-09 03:56:40 UTC
One way to deal with confidential information is to do a find/replace and just do a ton of replaces (replace all a's with o's for instance) and then do it a few times to make the document illegible. 



1) Is there any specific requirement for Java version?
no there shouldn't be

2) Is there any way I can enable logging?
http://ask.libreoffice.org/en/question/2044/libreoffice-logging-options/

might help

3) When the office suite crashes, is there any crash dump that gets created?
see above :)

4) I see a lot of people reporting the same issue in google. Were they resolved?
links?
Comment 10 Julien Nabet 2013-11-09 14:38:00 UTC
Sreekanth: you can also use this link https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace to provide more information.

Also, could you provide details about jre installed? (1.6, 1.7, 32 or 64 bits)

Please, read this Wikipedia page before telling Sun started this project:
http://en.wikipedia.org/wiki/StarOffice
Anyway, let's focus on the bug.
Comment 11 Björn Michaelsen 2014-01-17 11:08:50 UTC
(This is an automated message.)

This bug is not a MAB and in NEEDINFO, thus gradually adjusting priority to high. Please see the QA mailing list or the ESC call minutes for details.
Comment 12 m.a.riosv 2014-03-31 01:30:13 UTC
Hi @Sreekanth, any news about this issue, has been solved in some way?
Comment 13 Björn Michaelsen 2014-03-31 01:46:10 UTC
Likely a dupe of fdo#75898, can you retest with a daily build from:

 http://dev-builds.libreoffice.org/daily/

To see if its still there?
Comment 14 Sreekanth 2014-03-31 02:22:12 UTC
I couldn't reproduce it again and Open office seemed no so usable for me. So I moved to MS-Word as my current project at that time needs those documents to be ready.
Comment 15 retired 2014-03-31 08:42:16 UTC
Since we do not have a test file, nor is the user willing to test newer version, plus Björn assumes this might be fixed already and be a dupe, and reproducing on Ubuntu 13.10 LO 4.2 did not trigger any crash:

setting to WORKSFORME.