Bug Hunting Session
Bug 71331 - FORMATTING: Chinese and English hybrid format is not broken between words
Summary: FORMATTING: Chinese and English hybrid format is not broken between words
Status: RESOLVED DUPLICATE of bug 71329
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-07 06:08 UTC by shenxiaomao
Modified: 2014-04-26 07:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The result is very different in LibreWriter and in MSWORD。 (729.12 KB, application/x-zip-compressed)
2013-11-07 06:08 UTC, shenxiaomao
Details
example odt file (12.03 KB, application/vnd.oasis.opendocument.text)
2014-04-26 05:59 UTC, Kevin Suo
Details
pdf file showing current behaviour in 4.2.3.3 (26.33 KB, application/pdf)
2014-04-26 06:00 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shenxiaomao 2013-11-07 06:08:01 UTC
Created attachment 88807 [details]
The result is very different in LibreWriter and in MSWORD。

Problem description: 

Steps to reproduce:
1.As the attachment shows ,the style is not good because Writer automatically begin a new line from the middle of the first line。
2. At the end of the first line the blank is too long。

all the substences in the sample document is: 
"由于该厂区新建,部分厂区还没有建好,目前应用的信息化系统还较少,只有PDM、DNC,CAPP、ERP、MES系统暂时没有。从发展趋势来看,该厂会在近几年实施这些信息化系统,因为该厂的资金情况较好,且领导对信息化比较重视。 "

Current behavior:
Begining a new line from the middle of the first line

Expected behavior:
Begining a new line from the end of the first line an MSWord does.

              
Operating System: All
Version: 4.1.3.2 rc
Comment 1 Kevin Suo 2014-04-26 05:58:09 UTC
Reproduced in 4.2.3.3 Fedora 20 x86. Set to NEW.
Comment 2 Kevin Suo 2014-04-26 05:59:47 UTC
Created attachment 98006 [details]
example odt file

this file contains mixture of Chinese chars and english words. LibreOffice Writer has problem dealing with word-wrap.
Comment 3 Kevin Suo 2014-04-26 06:00:29 UTC
Created attachment 98007 [details]
pdf file showing current behaviour in 4.2.3.3
Comment 4 Urmas 2014-04-26 07:16:06 UTC

*** This bug has been marked as a duplicate of bug 71329 ***