Bug Hunting Session
Bug 71471 - Moving slides in slide sorter invalidates ALL custom styles applied to objects and revert them to default
Summary: Moving slides in slide sorter invalidates ALL custom styles applied to object...
Status: RESOLVED DUPLICATE of bug 62175
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.1:Ubuntu
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-11 08:43 UTC by Markus Michels
Modified: 2014-01-01 11:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Michels 2013-11-11 08:43:04 UTC
Third bug indicating that LO 4xy formatting is very broken.

Moving and/or copying a slide in the slide sorter reverts assigned custom styles to default.

Foreword: the style and format management features of LibreOffice are a clear USP over PPT. And I make heavy use of those. But with introduction of version 4 they simple do not work as intended and render this product useless for me (unfortunately, because I really do like LO).


Steps to reproduce:
Open impress, create new document
Add a shape (e.g. rectangle) to page
Open styles menu (hit F11)
Select rectangle
Click in styles menu "new style from selection"
Name it "watchamacallit"
Change the style settings (e.g. other background i.e. area color)
Add a second blank page
Save the document, close impress, re-open document - everything fine so far
Change the order of the slides in the slide sorter (left pane) by dragging THE EMPTY page from position 2 to position one
Save the document, close impress, re-open document - everything fine
Now change the order of the slides in the slide sorter (left pane) by dragging the page with our custom object from position 2 to position one
Save the document, close impress, re-open document
The custom shape has lost it's style assignment "watchamacallit" and reverted back to default which can be easily grasped from the different color since we changed the style

Expected behavior would be that the assigned style would be retained. This seems to be exactly the same problem as with "slide copy" (so copy the slide with custom shape within document instead of moving - this had been reported earlier and is still not yet resolved).
Comment 1 Robinson Tryon (qubit) 2013-12-22 15:27:05 UTC
CONFIRMED on Ubuntu 12.04.3 with
LibreOffice Version: 4.2.0.1

(In reply to comment #0)
> Steps to reproduce:
> Open impress, create new document
> Add a shape (e.g. rectangle) to page
> Open styles menu (hit F11)
> Select rectangle
> Click in styles menu "new style from selection"
> Name it "watchamacallit"
> Change the style settings (e.g. other background i.e. area color)

Right-click on 'watchamacallit' -> Modify -> 'Area' Tab -> Fill -> Color -> (pick a new color)
Then click 'OK'

> Add a second blank page

Insert -> Slide

> Save the document, close impress, re-open document - everything fine so far
> Change the order of the slides in the slide sorter (left pane) by dragging
> THE EMPTY page from position 2 to position one

Ok

> Save the document, close impress, re-open document - everything fine
> Now change the order of the slides in the slide sorter (left pane) by
> dragging the page with our custom object from position 2 to position one
> Save the document, close impress, re-open document

Ok

> The custom shape has lost it's style assignment "watchamacallit" and
> reverted back to default which can be easily grasped from the different
> color since we changed the style

CONFIRMED

> 
> Expected behavior would be that the assigned style would be retained. This
> seems to be exactly the same problem as with "slide copy" (so copy the slide
> with custom shape within document instead of moving - this had been reported
> earlier and is still not yet resolved).

Hi Markus - What's the bug # for the issue that's been previously reported?

Status: NEW
Comment 2 Markus Michels 2013-12-27 16:22:13 UTC
Hi,


initially I reported this as 62175... to my surprise it got closed and I reopened it...

Merry Christmas, and thanks for your help,


Markus
Comment 3 retired 2014-01-01 11:26:56 UTC
Sorry I don't get the rationale. If my head is still working in 2014 this would then be Dupe.

*** This bug has been marked as a duplicate of bug 62175 ***