Download it now!
Bug 71491 - Formula range not reverted at undo of a data move
Summary: Formula range not reverted at undo of a data move
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.3.0 target:4.2.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-11-11 13:16 UTC by Tomaz Vajngerl
Modified: 2014-03-18 21:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomaz Vajngerl 2013-11-11 13:16:13 UTC
Scenario:
A1: 1
A2: 2
A3: 3

B1: SUM(A1:A3)

Now move the data range (A1:A3) with the mouse to (A2:A4). When you do that, the formula SUM(A1:A3) is automatically adjusted to SUM(A2:A4). Now undo the move. The data is reverted but the formula still says SUM(A2:A4).

This happens in master but not in 4.1 so this is a regression in 4.2
Comment 1 GerardF 2013-11-11 14:57:36 UTC
Confirmed with Version: 4.2.0.0.alpha0+
Build ID: b7e5ab6f65eb682bfa200459d745d3bc4056e42a
TinderBox: Win-x86@42, Branch:master, Time: 2013-10-24_22:59:23

Formula is not updated/reverted after Undo.
Comment 2 m.a.riosv 2014-03-03 01:19:24 UTC
Still reproducible:
Win7x64Ult.
Version: 4.3.0.0.alpha0+ Build ID: 09155190d817dd880cc96a106114618b46a5a7e5
   TinderBox: Win-x86@39, Branch:master, Time: 2014-03-01_23:56:24
Comment 3 Kohei Yoshida 2014-03-14 13:50:46 UTC
I didn't see this because the version tag "4.2.0alpha...." was not in my search term. :-(
Comment 4 Tomaz Vajngerl 2014-03-14 15:49:55 UTC
In the mean time I also forgot about it. Doesn't seem so important if I was the only one that reported this :)
Comment 5 Kohei Yoshida 2014-03-15 03:21:52 UTC
(In reply to comment #4)
> In the mean time I also forgot about it. Doesn't seem so important if I was
> the only one that reported this :)

Well, that may be true. But this sort of reference update is expected to be working, so it's best to fix this before anybody else notices it. ;-)
Comment 6 Commit Notification 2014-03-15 04:17:07 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=980898058f1411d234c009caaae58b29eb3420c8

fdo#71491: Write test for this.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-03-15 04:17:27 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88955714d345d8584e86ae34bf5f5d1f3f4af9f7

fdo#71491: Adjust reference during undo of drag-n-drop of cell range.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Kohei Yoshida 2014-03-15 04:44:44 UTC
Fixed.
Comment 9 Commit Notification 2014-03-17 13:43:41 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b85f07986dc005ea0a74baa3d14ee0fd1ec99609&h=libreoffice-4-2

fdo#71491: Adjust reference during undo of drag-n-drop of cell range.


It will be available in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Tomaz Vajngerl 2014-03-17 13:56:40 UTC
Nice.. works flawlessly now in master.
Comment 11 m.a.riosv 2014-03-18 21:27:51 UTC
Verified in:
Version: 4.2.4.0.0+ Build ID: e1823627f35e4419880769fdd05acddbd0a9c25c
   TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-03-18