Download it now!
Bug 71503 - EDITING: Inserting of a Paragraph above a Table of Contents is not Possible
Summary: EDITING: Inserting of a Paragraph above a Table of Contents is not Possible
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: TableofContents-Indexes
  Show dependency treegraph
 
Reported: 2013-11-11 15:42 UTC by Harald Koester
Modified: 2020-08-02 11:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2013-11-11 15:42:49 UTC
Problem description: 

Steps to reproduce:
[1] Open a new text document.
[2] Disable option “LibreOffice Writer → Formatting Aids → Cursor in protected areas“.
[3] Insert a heading.
[4] Insert a protected (against manual changes) Table of Contents above the heading line: Insert > Indexes and Tables > Indexes and Tables... > Tab "Index/Table", Type: "Table of Contents" > OK. 
[5] Now it is not possible to insert a paragraph above the table of contents. Expected: It should be possible to move the cursor in front of the “T“ of “Table of Contents“. Then Alt+Enter should insert a new paragraph above the table.

If you enable the option in step [2] it is possible to move the cursor in front of the “T“, but it's still not possible to insert a new paragraph.

See also enhance proposal in bug 51689 according creating paragraphs above and below of tables, indexes and sections.
Operating System: Windows 7
Version: 4.1.2.3 release
Comment 1 Jean-Baptiste Faure 2013-11-25 06:06:58 UTC
Reproducible but, for me, it is not a bug, only an enhancement.
That said there is an easy workaround: remove the ToC, insert the paragraph, insert the ToC. As inserting a ToC is automatic, it is very easy to do.

Note: IMHO, the need of this enhancement comes from a workflow that does use templates as it should. It is weird to create a ToC at the top of the document, the beginning of the document is the place of the title, not of the ToC.

Best regards. JBF
Comment 2 Heiko Tietze 2019-12-05 08:08:20 UTC Comment hidden (off-topic)
Comment 3 Harald Koester 2020-02-27 15:41:01 UTC Comment hidden (off-topic)
Comment 4 Heiko Tietze 2020-03-02 16:58:45 UTC Comment hidden (off-topic)
Comment 5 Timur 2020-08-02 11:09:35 UTC
I don't see a point in this bug.
Default setting is with "Enable cursor". If someone turns it off, s/he should know why and what's the consequence. 
Also, ToC is usually not the first. Even if this happens, easy to recreate with an empty paragraph above.
All in all, so many conditions for a small gain and very rare situation, if ever.
My general view is that any enhancement is welcome, whenever and if ever is done. 
But I don't see as an enhancement at all, this is rather solving of unbelievable situation.
So I set WontFix. 
If I (as QA) am wrong, UX may change.

Note: there's a hang that I'll report separately.
Comment 6 Timur 2020-08-02 11:16:38 UTC
(In reply to Harald Koester from comment #0)
> If you enable the option in step [2] it is possible to move the cursor in
> front of the “T“, but it's still not possible to insert a new paragraph.

With default setting Of "Enable cursor", it is possible to insert a new paragraph above ToC, with double Alt+Enter (can't says why double).
So that would be WFM. Test with LO 7.1+.