Download it now!
Bug 71518 - EDITING: Select only visible cells like in excel
Summary: EDITING: Select only visible cells like in excel
Status: RESOLVED DUPLICATE of bug 36466
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-12 02:53 UTC by Plavozont
Modified: 2014-04-25 15:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Case: hide yellow columns and yellow row, copy only what you need and paste it on a second sheet (9.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-11-12 13:23 UTC, Plavozont
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Plavozont 2013-11-12 02:53:31 UTC
Problem description: 

Steps to reproduce:
1. filter somthing in a table or hide some rows/columns in it
2. select some range in that table including hidden cells
3. press [F5] like in Excel
4. click [select...] like in Excel
5. choose select only visible sells like in Excel
6. click ok

Current behavior:
functionality is missing, I have to select only visible cells by holding CTRL button, using extensions or macroses, this is very uncomfortable

Expected behavior:
only visible cells should present in the selection allowing to copy/paste only them

Comments:
Selecting unbounded ranges has been implemented already in LibreOffice, implementing "select only visible sells" is a piece of cake, I know you guys don't care about marketing goals like Microsoft, you care about users, please implement this for me, I need it very much.
Operating System: Windows XP
Version: 4.1.3.2 release
Comment 1 Ady 2013-11-12 06:42:18 UTC
According to https://help.libreoffice.org/Calc/Only_Copy_Visible_Cells you should already be able to select a range and only copy the visible cells, at least when using autofilter.

So, if I understand correctly, you are actually requesting an enhancement, so to be able to decide each time whether you want all cells copied (including hidden cells), or just visible cells, and independently of which method was used to hide cells.

IIRC, there used to be an extension too.

If you have a case in which Calc does not behave as described in https://help.libreoffice.org/Calc/Only_Copy_Visible_Cells then please attach an example.
Comment 2 Cor Nouws 2013-11-12 08:30:13 UTC
Hi,


> 3. press [F5] like in Excel

F5 does something else in LibreOffice...

> Current behavior:
> functionality is missing, I have to select only visible cells by holding
> CTRL button, using extensions or macroses, this is very uncomfortable

Ctrl+Shift+Arrow works?

Mybe I don't get you right?
Cheers,
Cor
Comment 3 Gerry 2013-11-12 08:57:54 UTC
Isn't this an enhancement request? 
There is also an extension providing this feature: http://extensions.libreoffice.org/extension-center/copy-only-visible-cells
Comment 4 Plavozont 2013-11-12 13:21:43 UTC
Besides I would like to be able to select only empty cells like in excel([F5]->select...->empty cells->OK) in other words I would like some dialog that helps selecting
Comment 5 Plavozont 2013-11-12 13:23:19 UTC
Created attachment 89085 [details]
Test Case: hide yellow columns and yellow row, copy only what you need and paste it on a second sheet

Imagine that you’ve received by a mail a very large table a with a lot of columns and even more columns are hidden, you need a small bit of that information, you are selecting and copying what you need, pasting some place you want and see that you’ve captured at least half of that table and you have no idea which part of that is what you wanted.
Comment 6 Cor Nouws 2013-11-12 21:33:45 UTC
(In reply to comment #5)
> Imagine that you’ve received by a mail a very large table a with a lot of
> columns and even more columns are hidden, you need a small bit of that
> information, you are selecting and copying what you need, pasting some place
> you want and see that you’ve captured at least half of that table and you
> have no idea which part of that is what you wanted.

Hmm. sounds rather vague to me.
Do you know the name-box and it's use?
Comment 7 Plavozont 2013-11-13 01:40:01 UTC
> Hmm. sounds rather vague to me.

To be clear, I use a LOT of selecting only visible cells not inside of a filter at my work, and I often use Calc functionality that is missing in Excel(like regular expressions, or when xls file gets abnormally big and need ridiculously much time to save, then I re-save it with Calc, or when I need to set optimal row heights - excel handles merged cells wrong, also the VLOOKUP function is buggy) and when I switch to Calc I miss selecting only visible cells, and I have to switch back to Excel, than back to LibreOffice, than back to Excel e.t.c. Of course I can use an extension but I always thought that Calc should support Excel users, it should taste like Excel only sweeter, I know  that it will never do everything that Excel does but it can do similar things and do them better because you are not holded by marketing.

> Do you know the name-box and it's use?

Amm, I use it almost never, how can it help?
Comment 8 Kevin Suo 2014-04-25 15:13:24 UTC
This is the feature many users are wondering.

Set to new. (not sure why it was set to needinfo.)

By the way, the 'select only visible cell' extention seems not working with 4.x anymore.
Comment 9 Kevin Suo 2014-04-25 15:22:07 UTC

*** This bug has been marked as a duplicate of bug 36466 ***