Bug 71521 - FILESAVE: File locking is broken
Summary: FILESAVE: File locking is broken
Status: RESOLVED DUPLICATE of bug 67534
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:4.2.0) (target:4.1.4)
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-12 05:43 UTC by chebmaster
Modified: 2013-11-19 08:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chebmaster 2013-11-12 05:43:23 UTC
Problem description: 

1. Writer gives incorrect warnings that the document is opened by me  "in another system" (в другой системе)

2. Lock files are not deleted after closing the document, thus littering.


Steps to reproduce:

1. Open any document for editing or create a new document

2. Try to save it (save it for the second time for the newly created document)


Current behavior:

At every saving of every document Writer displays the following dialog: 

(my translation): 
File of document "test.odt" is blocked for editing by yourself in another system since 11.12.2013 09:24

Close document in another system or ignore your own blocking and save current version of document.

Repeat saving / Save / cancel

(original):
Файл документа «test.odt» заблокирован для редактирования Вами же в другой системе с 12.11.2013 09:24

Закройте документ в другой системе и повторите сохранение или игнорируйте свою собственную блокировку и сохраните текущий вариант документа.

Повторить сохранение / Сохранить / Отмена



Expected behavior:

Recognize its own lock files as its own, not somebody else's

Notes:

1. I can delete the lock files, so this is not a permissions problem. This gives me one saving attempt working as expected. Then the lock file gets re-created and the next saving brings that warning again.

2. This bug appeared suddenly. I think it was after an update, but I'm not completely sure. I was previously using version 4.something
              
Operating System: Windows 7
Version: 4.1.3.2 release
Comment 1 Julien Nabet 2013-11-12 18:47:46 UTC
It could be a dup of fdo#67534 (put in "See also" and fixed for the next LO release 4.1.4)
Please run LibreOffice installation, choose 'Modify' and uncheck the installation of Windows Explorer extensions. Does it solve your problem?
Comment 2 chebmaster 2013-11-13 06:34:01 UTC
Yes, unchecking it solved the problem.

Additional information: This bug may be related to hibernation.
 
After discovering it, I reverted to 4.0.6. It was working for a while, but after I opened a document, then hibernated my machine for the night, then woke it up, saving that still opened document produced that warning again!

With explorer extensions disabled, document saves normally in 4.1.3.2 even after hibernation.
Comment 3 Julien Nabet 2013-11-13 06:36:27 UTC
chebmaster: thank you for your feedback, it confirms it's a dup.

*** This bug has been marked as a duplicate of bug 67534 ***
Comment 4 chebmaster 2013-11-18 10:01:57 UTC
The bug is back, even though explorer extensions are not installed.

May be a conflict with antivirus: it coincides with ESET Smart Security 7 updating its program modules.

Is there an option to DISABLE file locking?
Comment 5 Maxim Monastirsky 2013-11-18 11:13:13 UTC
(In reply to comment #4)
> The bug is back, even though explorer extensions are not installed.
Might be a sign of a corrupted profile. Could you please reset your profile as described at https://wiki.documentfoundation.org/Faq/General/110.

Also take a look at the user name mentioned in the lock file, does it correct?
Also go to Tools->Options...->LibreOffice->User Data and compare the user name mentioned there. Try to set it to be *exactly* the same as your system user name (and clear other fields).

> May be a conflict with antivirus: it coincides with ESET Smart Security 7
> updating its program modules.
Might be, especially if you have a slow computer.

> Is there an option to DISABLE file locking?
You could try http://ask.libreoffice.org/en/question/4055/how-can-i-unlockwriter-documents-to-edit-on-another-computer/. Didn't try it, so do it on your own risk.
Comment 6 chebmaster 2013-11-19 08:07:11 UTC
For now, the bug has disappeared (after hibernating and waking up), so I would not be able to tell if resetting the profile worked. I also don't have any old lock files.

If it acts up again, I'll definitely try it and report here.