Download it now!
Bug 71536 - EDITING: ctrl button cell selection bug
Summary: EDITING: ctrl button cell selection bug
Status: RESOLVED DUPLICATE of bug 37230
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-12 14:59 UTC by Burak Ural
Modified: 2013-11-15 08:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Burak Ural 2013-11-12 14:59:02 UTC
Problem description: I am in a cell with data, the cells below has no data. When I move to another cell pressing shift button and then hold pressing ctrl button(shift still pressed) to select the cell with data, at the end of the column , the selection goes all the way to the bottom of all the cells including empty cells.

Steps to reproduce:
1. To test have a sheet with data 2x10 formation.
2. Have the 10 cells in first column fill with data.
3. Have the 1st cells in second column fill with data.
4. Make sure rest of cells in second column has no data.
5. Goto cell B2 , it should have data in it.
6. Press shift , while holding shift press left once keeping shift pressed.
7. While keeping shift pressed, press and hold ctrl button.
8. While keeping shift and ctrl pressed , press down arrow.

Current behavior:
The cells A1 to B1048576 selected.
Expected behavior:
The cells A1 to B10 selected.
Operating System: Windows XP
Version: 4.1.3.2 release
Comment 1 Cor Nouws 2013-11-12 22:06:30 UTC
Hi Burak,

IIRC, this behaviour has been discussed before and is like this intentional.

You can start in B1, hit Shift+Right and then Ctrl+Shift+Down ?
Comment 2 Burak Ural 2013-11-13 12:19:13 UTC
(In reply to comment #1)
> Hi Burak,
> 
> IIRC, this behaviour has been discussed before and is like this intentional.
> 
> You can start in B1, hit Shift+Right and then Ctrl+Shift+Down ?

Hi,

If this is intentional, for the sake of compatibility of usage with other office software , it should be like the way I have described.
Because it is exactly like that, in MS Excel, Openoffice Calc , Kingsoft Office.

This is a standard behavior and it is causing serious difficulty for people who are used to other similar software.

The aim of office software should be easiness and efficiency.

Best Regards,
Burak Ural
Comment 3 Cor Nouws 2013-11-13 20:55:23 UTC
Hi Bukal,

What I remembered, was only part of the story. Sorry. 

See bug 37230 for more details. Short: there is a choice in 4.2.0 ;)

Cheers,
Cor

*** This bug has been marked as a duplicate of bug 37230 ***
Comment 4 Tomaz Vajngerl 2013-11-13 23:01:59 UTC
Actually.. it is exactly not like that in MS Excel or Kingsoft Office. This is one of the reasons for change - the other is that the old behavior was actually a side-effect of a bug. But because the old behavior is a lot cooler I implemented it as an option.
Comment 5 Burak Ural 2013-11-15 08:22:04 UTC
(In reply to comment #4)
> Actually.. it is exactly not like that in MS Excel or Kingsoft Office. This
> is one of the reasons for change - the other is that the old behavior was
> actually a side-effect of a bug. But because the old behavior is a lot
> cooler I implemented it as an option.

Hi,

I can not find the option to change this behaviour.
In the bug thread, "expert config" is being mentioned.
Where do we find the expert config page and the options?
How is it accessed in an installed Libreoffice?

Regards,
Burak Ural