Bug 71584 - FILEOPEN: FORMATTING: formatting error in a file with two tables
Summary: FILEOPEN: FORMATTING: formatting error in a file with two tables
Status: RESOLVED DUPLICATE of bug 61594
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA Confirmed:4.2.0.0.alpha0+:Windows...
Keywords: regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-11-13 16:44 UTC by Denis Bizzotto
Modified: 2014-01-15 21:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File with two tables (21.87 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-11-13 16:44 UTC, Denis Bizzotto
Details
this is what I see (41.43 KB, application/pdf)
2013-11-14 11:43 UTC, Denis Bizzotto
Details
Tommy27 screenshot (57.90 KB, image/png)
2013-11-14 13:57 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Bizzotto 2013-11-13 16:44:20 UTC
Created attachment 89157 [details]
File with two tables

Problem description: 

Steps to reproduce:
Open the attached file with libreoffice writer

Current behavior:
2 tables overlapped

Expected behavior:
one table under the other
              
Operating System: Windows 8
Version: 4.1.2.3 release
Comment 1 tommy27 2013-11-14 06:32:23 UTC
I see no overlapping on 4.1.3.2 under Win7 64bit
would you please post a screenshot of what you see?
Comment 2 Denis Bizzotto 2013-11-14 11:43:57 UTC
Created attachment 89184 [details]
this is what I see

As you can see, from a docx file with two tables on two pages, with writer I see a file with one page and two overlapped tables.
Comment 3 tommy27 2013-11-14 13:57:38 UTC
Created attachment 89192 [details]
Tommy27 screenshot

I still confirm that your file renders correctly in LibO 4.1.3.2 under Win7 64bit. see my screenshot.

I suspect a corruption in your user profile.
try resetting (backup first) you profile and tell us what happens.
instructions here: https://wiki.documentfoundation.org/UserProfile
Comment 4 tommy27 2013-11-14 13:58:56 UTC
(In reply to comment #0)
>
> ....
>               
> Operating System: Windows 8
> Version: 4.1.2.3 release

additional info required:

Win8 32 or 64bit version?
did you try that file with other Windows O/S like Win7 or WinXP?
Comment 5 Thomas van der Meulen 2013-11-15 17:08:35 UTC
All tested with a new user-profile 
os: Mac osx 10.9

It worked fine in: 
Version 3.6.7.2 (Build ID: e183d5b)

but the oldest version that I tested with and the bug was is: 
Version 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-03-26_15:52:16
(I did not test with older 4.0 builds.) 

until:
Version: 4.1.2.3
Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38

and it seems to be fixed since Version: 4.1.3.1
Build ID: b42498da0e3f91b17e51b55c8295ec4f8f22087


But in 4.2.x it seems to be there again.
Version: 4.2.0.0.alpha1
Build ID: c2b9ad37f8a8de9c7dbdd76c86aecf6388107056

Version: 4.2.0.0.alpha1+
Build ID: 868103846b9b32bfecd77c08055fdca69d0265c2
TinderBox: MacOSX-x86@48-TDF, Branch:master, Time: 2013-11-14_23:51:46


Maybe related to bug 61594, any idea's?
Comment 6 tommy27 2013-11-16 07:50:16 UTC
@Denis Bizzotto
I confirm bug is present in 4.1.2.3 while it is fixed in 4.1.3.2
so I reccommend to upgrade to stable 4.1.3 final release to get rid of this bug

@Thomas van der Meulen

you are right. the bug is already present in

Version: 4.2.0.0.alpha0+
Build ID: 86b79ea1f6afb709f2de8141810a61e4162e3125
TinderBox: Win-x86@42, Branch:master, Time: 2013-11-01_23:37:14

so something fixed it during 4.1.2 --> 4.1.3 development but something broke it again in 4.2 development

basically issue is fixed in stable branch and a regression take place in the developing branch
Comment 7 Robinson Tryon (qubit) 2013-11-24 05:15:23 UTC
Add info to whiteboard re: where this bug can/can't be repro'd.
Comment 8 Robinson Tryon (qubit) 2013-11-24 05:24:34 UTC
CONFIRMED in LO 4.2.0.0.beta1 on Ubuntu 12.04.3

(Also add another repro datapoint to whiteboard)
Comment 9 Michael Stahl (CIB) 2014-01-15 21:30:27 UTC
it's another one of those floating tables which Writer can't handle properly anyway.

*** This bug has been marked as a duplicate of bug 61594 ***