Download it now!
Bug 71594 - FILESAVE: Libreoffice crash while saving
Summary: FILESAVE: Libreoffice crash while saving
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: high major
Assignee: Rohit Deshmukh
URL:
Whiteboard: target:4.3.0
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2013-11-14 06:53 UTC by Vinu Kadu
Modified: 2014-01-03 12:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File need to be saved (41.17 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-11-14 06:53 UTC, Vinu Kadu
Details
console + bt with master sources (24.29 KB, text/plain)
2013-11-14 21:28 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vinu Kadu 2013-11-14 06:53:19 UTC
Created attachment 89174 [details]
File need to be saved

Steps to reproduce:

Open file in LibreOffice
Click File -> Save As (.docx)

Current behavior:
Crashing on every save.

Expected behavior:
Creating the file correctly
Comment 1 retired 2013-11-14 11:07:01 UTC
Hi Vinu, please don't set your own bug to NEW. Wait for the QA team or someone else to confirm it.

Can confirm a crash when saving the test file as docx with LO 4.1.3.2 on OS X 10.9.

Crash log (available 1 month from now): http://pastebin.com/hgvv4Qze
Comment 2 Julien Nabet 2013-11-14 21:28:49 UTC
Created attachment 89238 [details]
console + bt with master sources

On pc Debian x86-64 with master sources updated today, I reproduced the crash.

I attached console logs (at the opening + during saving try) + bt
Comment 3 Julien Nabet 2013-11-14 21:30:20 UTC
Put 4.1.3.2 for the moment.
+ All (since it concerns at least MacOs + Linux)
Comment 4 Rohit Deshmukh 2013-11-19 13:29:41 UTC
At the time of export of document.xml,
Tags gets export as follows:
<document>
<body>
<tbl>
<sectPr>
<ftr> # Writing footer1.xml
</tbl>
</ftr>
<ftr> # Writing footer2.xml
<tbl>
</tbl>
</sectPr> # Written in document.xml
<tbl>
</tbl>
<sectPr>
</sectPr>
</body>
</document>

So we are facing issue in start table in footer1.xml
Comment 5 altafreccia 2013-11-20 16:37:23 UTC
Crash occurs also when attemping saving in .odf format or when saving tamplates.
Comment 6 Julien Nabet 2013-11-20 18:33:55 UTC
Michael: according some recent commits from you, I thought you might be interested in this one? (bt includes sax/source/tools/fastserializer.cxx)
Comment 7 Michael Meeks 2013-11-20 19:47:51 UTC
Heh - thanks for the CC - we didn't touch the FastSaxSerializer only the FastSaxParser (ie. load not save). Sorry about that. I guess the core code is somehow generating an invalid sequence of XML to be output and the serializer just doesn't like that & complains / crashes.

So - the problem would be higher up in writer somewhere.
Comment 8 Julien Nabet 2013-11-20 19:54:13 UTC
Michael: oups sorry for the noise! I should have double checked the name of the file :-)
Comment 9 Rohit Deshmukh 2013-11-21 05:51:40 UTC
Hi  Julien & Michael, I fixed the this issue.
The fix is in export part of Writer. So file is able to save and Open in MS office 2010
Comment 10 Julien Nabet 2013-11-21 06:08:34 UTC
Rohit: do you mean with this commit?
http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7ff594a9c879ea3ae437e0f7602ef26642e6fc7
Comment 11 Rohit Deshmukh 2013-11-21 06:56:22 UTC
 Julien: No. I am writing UT for this fix. I will put for review today.
Comment 12 Commit Notification 2013-12-13 12:49:37 UTC
Rohit Deshmukh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=29c079f0480f63dd3f046f30c2b81023c2a5aebf

fdo#71594: Fix for LO crash while saving of file.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 retired 2013-12-13 13:06:14 UTC
Rohit: does your commit mean, this can be set to fixed?
Comment 14 Julien Nabet 2013-12-13 13:14:55 UTC
Foss: it could be interesting first to cherry-pick this on 4.2 branch at least, and if possible on 4.1 branch.