Bug 71601 - CONFIGURATION: Remove "presentation->Always start from current slide"-option in options-dialog
Summary: CONFIGURATION: Remove "presentation->Always start from current slide"-option ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: All All
: medium normal
Assignee: Rob Snelders
URL:
Whiteboard: BSA target:4.3.0
Keywords:
: 67506 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-14 10:44 UTC by Daniel
Modified: 2014-11-06 04:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2013-11-14 10:44:11 UTC
Problem description: 

Presentation option / config to start with current or first slide does not have impact on presentation mode, it always starts with the first slide.

Furthermore, I am not even able to disable the option to check the behaviour as it stays on on opening config/options (even when disabled and closed), not working.

Steps to reproduce:
1. Go to Options->Impress->General->Presentation->
2. enable Always...
3. go to presentation mode (F5), first slide is shown

Current behavior:
first slide is shown
user is not able to disable/enable option at their will (stays always checked)

Expected behavior:
currently selected slide is shown
user is able to disable/enable option at their will
              
Operating System: Ubuntu
Version: 4.1.1.2 release
Comment 1 Jorendc 2013-11-14 23:05:34 UTC
Thanks for reporting!

I can reproduce this behavior, tested using Mac OSX 10.9 with LibreOffice Version: 4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

Also with Version: 4.2.0.0.alpha1 Build ID: 496e2be9dd6eb96d120d412760422eaa904b7f71

Kind regards,
Joren
Comment 2 gqqnbig 2013-11-16 22:20:40 UTC
Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

also has the same problem.
Comment 3 Rob Snelders 2014-02-04 08:49:10 UTC
As we have a option to start from current slide, i can't see why we would need this option.
Comment 4 Rob Snelders 2014-02-04 08:52:31 UTC
To start from current slide go to "SlideShow -> Start from current slide" or press shift+F5.

As this is possible I would suggest removing the option from the dialog.
Comment 5 Rob Snelders 2014-02-04 12:20:23 UTC
I removed the option from the options-dialog (https://gerrit.libreoffice.org/7842)
Comment 6 Commit Notification 2014-02-18 20:36:11 UTC
Rob Snelders committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=12b78edde94af7550b14382d9bfd1c77854e5fb0

Remove from option-dialog the CurrentPage-option (fdo#71601)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Thorsten Behrens (CIB) 2014-11-05 22:38:56 UTC
*** Bug 67506 has been marked as a duplicate of this bug. ***
Comment 8 Carlos 2014-11-06 04:38:02 UTC
Good to have marked the other thread as duplicate and having removed the option but, what about reverting the "Start slideshow" button to its old behaviour? Or better, to let users choose which behaiour they desire?