Bug Hunting Session
Bug 71606 - Other: User's Alphabetic index : concordance file don't read all registered words
Summary: Other: User's Alphabetic index : concordance file don't read all registered w...
Status: RESOLVED DUPLICATE of bug 46410
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-14 12:19 UTC by D. Petridis
Modified: 2014-01-26 03:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description D. Petridis 2013-11-14 12:19:44 UTC
Problem description: 
The option "index file" chosen in the window "insert index/tables" performs improperly

Steps to reproduce:
in English and Greek also
1.Insert (Εισαγωγή)
2. Index/Tables (Ευρετήρια και πίνακες)
3. Index/Tables  (Ευρετήριο και πίνακες)
4. Type: Alphabetic index plus Options: Index file (Τύπος: Αλφαβητικό ευρετήριο και Επιλογές: Αρχείο ταξινόμησης)
5. Open File (Άνοιγμα αρχείου)

Current behavior:
The index file when it runs does not read the words in the text or recognizes too few words only. This happens in all versions greater than 3.5
Expected behavior:
It must produce a list of words recorded in the index file 
              
Operating System: Windows 8
Version: 4.0.6.2 release
Comment 1 Dominique Boutry 2013-11-19 14:11:59 UTC
Hi

In LibO 4.1.2.3 EN on Win7, I can find type:Alphabetical index, but not the Option "Index file", so I can't try to reproduce the bug.
Comment 2 D. Petridis 2013-11-21 15:03:15 UTC
Hi there

Thank’ s for the great interest. 

The next option after  Alphabetical index is Concordance file  and next choose Open

Best regards

D. Petridis

 

From: bugzilla-daemon@freedesktop.org [mailto:bugzilla-daemon@freedesktop.org] 
Sent: Tuesday, November 19, 2013 4:12 PM
To: petridis@food.teithe.gr
Subject: [Bug 71606] Other: User's Alphabetic index problem

 

Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=71606#c1>  on bug 71606 <https://bugs.freedesktop.org/show_bug.cgi?id=71606>  from  <mailto:dominique.boutry3@laposte.net> Dominique Boutry 

Hi
 
In LibO 4.1.2.3 EN on Win7, I can find type:Alphabetical index, but not the
Option "Index file", so I can't try to reproduce the bug.
  _____  


You are receiving this mail because: 

*	You reported the bug.
Comment 3 Dominique Boutry 2013-11-23 09:00:30 UTC
Hi

You wrote :
<The index file when it runs does not *read the words in the text* or recognizes too few words only. This happens in all versions greater than 3.5
Expected behavior:
It must produce a list of words *recorded in the index file*>

As far as I correctly understand the online help, the Concordance File is *read* during the process, not *written*...
Comment 4 Dominique Boutry 2013-11-26 10:13:23 UTC
After deeper inspection :
- reproduced with LibO 4.1.2.3 on Win7
- FYI, OK with AOO 4.0.
Comment 5 sophie 2014-01-08 14:10:21 UTC
Hi, 
I couldn't reproduce using Version: 4.2.0.1
Build ID: 7bf567613a536ded11709b952950c9e8f7181a4a - Could you please attach a concordance file in English or at least how many words do you have in this file (mine has about 15 entries) all of them are recognized. May be also, it's a Windows only version, Dominique seems to have reproduced the bug, but didn't put it on New - Sophie
Comment 6 D. Petridis 2014-01-08 18:38:00 UTC
Hi Sophie

Version 4.1.4.2 reproduced perfectly all the key-words I used as index (entries were more than 200 but in Greek).

Unfortunately I have no context in English, so Dominique had to create his own file and used it with successful results.

 

 

From: bugzilla-daemon@freedesktop.org [mailto:bugzilla-daemon@freedesktop.org] 
Sent: Wednesday, January 08, 2014 4:10 PM
To: petridis@food.teithe.gr
Subject: [Bug 71606] Other: User's Alphabetic index problem

 

 <mailto:gautier.sophie@gmail.com> sophie changed bug 71606 <https://bugs.freedesktop.org/show_bug.cgi?id=71606>  


What

Removed

Added


CC

  

gautier.sophie@gmail.com 

Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=71606#c5>  on bug 71606 <https://bugs.freedesktop.org/show_bug.cgi?id=71606>  from  <mailto:gautier.sophie@gmail.com> sophie 

Hi, 
I couldn't reproduce using Version: 4.2.0.1
Build ID: 7bf567613a536ded11709b952950c9e8f7181a4a - Could you please attach a
concordance file in English or at least how many words do you have in this file
(mine has about 15 entries) all of them are recognized. May be also, it's a
Windows only version, Dominique seems to have reproduced the bug, but didn't
put it on New - Sophie
  _____  


You are receiving this mail because: 

*	You reported the bug.
Comment 7 Owen Genat (retired) 2014-01-26 03:40:18 UTC
Bug 46410 fixed a long-standing issue with a concordance file not marking all required entries. Fix was provided for v4.1.4 and v4.2.0. This report would appear to be a duplicate (and comment #5 and comment #6 would seem to indicate this issue is now fixed). I am setting this report RESOLVED as a DUPLICATE.

*** This bug has been marked as a duplicate of bug 46410 ***