Bug 71648 - Crash: Unable to register Databases
Summary: Crash: Unable to register Databases
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: haveBacktrace
Depends on:
Blocks: 84586
  Show dependency treegraph
 
Reported: 2013-11-15 14:53 UTC by olivier_musson
Modified: 2014-10-02 07:18 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Backtrace LO 4.1.3.2 (65.31 KB, text/plain)
2013-11-25 20:06 UTC, olivier_musson
Details
Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20 (181 bytes, application/gzip)
2014-10-01 08:24 UTC, Marina Latini (SUSE)
Details
Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20 (3.18 KB, application/gzip)
2014-10-01 09:52 UTC, Marina Latini (SUSE)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description olivier_musson 2013-11-15 14:53:32 UTC
Problem description: 

Steps to reproduce:
1. Start LibreOffice
2. Choose Menu -> Options
3. LibreOffice Base -> Connections or -> Databases

Current behavior:
LibreOffice crash with no message no error. I can reproduce problem on 2 PC's and 1 laptop all running OpenSuse 12.3

Expected behavior:
Open Databases option to register existing databases.
              
Operating System: openSUSE
Version: 4.1.3.2 release
Comment 1 Robert Großkopf 2013-11-15 18:13:53 UTC
Same system here: OpenSUSE 12.3 64bit rpm. No problems to register any database with LO 4.1.3.2 release, also with other LO-Versions.
Where did you get 4.1.3.2 from?
Have you tried to rename in your home-directory .config/libreoffice/4 ? It would be reinstalled when you restart LO ...
Comment 2 olivier_musson 2013-11-15 22:31:33 UTC
Btw I run also 12.3 64bit on all my PC's. Sorry I forgot to specify it.

Yes I tried to rename or delete ./config/libreoffice/4 and result is the same.

I got 4.1.3.2 with update from OpenSuse yesterday evening from this repo I guess URL : http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_12.3/
It says 4.1.3.2 build id 410m0 Build 2 supplied by SUSE.

I tried tonight on 2 other PC (in total I tried on 5). Result tonight is :
first one running LO 4.0 build 305 build id 400m0 and result is the same crash. I upgraded it to 4.1.3.2 and result is the same it crash.
second one running LO 4.1.3.2 build 2 build id 410m0 and it's working fine. What I noticed on this PC is that existing DB I use are already registered there. So when I go to Options -> Databases it works fine because list is not empty I guess but not sure.

For all the others where it's failing and crash I guess the list of registered DB is empty. Of course I can't be sure of it as I can't see the list of registered DB there by default like Bibliography. But my guess is it's empty. Again not sure.

Do you know if there is a way to register an entry in other way than with Options -> Databases in GUI ?

I could delete the entire list and see if with an empty list it fail but sorry it's the onlyPC where it works fine and I need it so I can't do this test. May be you could try ?
Comment 3 Robert Großkopf 2013-11-16 09:59:29 UTC
(In reply to comment #2)
> 
> Yes I tried to rename or delete ./config/libreoffice/4 and result is the
> same.

If you are using the SuSE-version the name of the folder is 4-suse. I have such a folder here in that path, but not the 4.1.3.2 from openSUSE, only 4.1.1.2. from another repo.

> 
> I could delete the entire list and see if with an empty list it fail but
> sorry it's the onlyPC where it works fine and I need it so I can't do this
> test. May be you could try ?

I have deleted all entries in the register in my LO 4.1.3.2, directly from LO. I restarted 4.1.3.2 and could register new databases.

Could you please report the same you reported here to https://bugzilla.novell.com/index.cgi ? Seems to be it is a bug of the packages of OpenSUSE.
Comment 4 olivier_musson 2013-11-16 11:38:21 UTC
Yes sorry folder is 4-suse but result is the same.

On working PC I deleted all registered databases an like you was able to register new  one. On all others it crash.

I reported the bug where you told me : https://bugzilla.novell.com/index.cgi

Thanks for your help.

Olivier
Comment 5 Julien Nabet 2013-11-22 06:12:33 UTC
Olivier: would it be possible you try to retrieve a backtrace by following this link? https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 6 olivier_musson 2013-11-22 11:05:01 UTC
Julien: it's pity because I had a core this week but I don't have it anymore as I update my PC at work to Opensuse 13.1 and now problem is gone. I still have other PC with Opensuse 12.3 and LO 4.1.3.2 so I will reproduce it when back home. When it crashed java generated a core.

I will retrieve back trace for you at home ...
Comment 7 olivier_musson 2013-11-25 18:34:37 UTC
I couldn't take a backtrace with the command advised in the link you gave me as LO was hanging staring with : soffice --backtrace. Reproducing my problem I got a core java dump but it's too be and can't be attached to this thread. How can I send it to you ?
Comment 8 Julien Nabet 2013-11-25 19:42:01 UTC
Olivier: there's perhaps you could try the old manner:
- launch LO from a first terminal/console
- open a new terminal/console and run this:
  - LOPID=$(pidof soffice.bin)
  - gdb soffice.bin $LOPID
  - type "c" (without quotes) then enter

Go back to first terminal/console and reproduce the crash, at the very moment where you should have the crash, there'll be an hanging, at this moment go to second terminal/console and you should see a segfault or something, just type:
bt (to retrieve a backtrace)

If you got several "?", type c (for "Continue") until another it stops again then try again "bt".
Comment 9 olivier_musson 2013-11-25 20:06:57 UTC
Created attachment 89771 [details]
Backtrace LO 4.1.3.2

Thanks for your help it worked. Attached is the bt I took as a txt file. Here are information I got from the first console where I started LO.

If you need more info please let me know.

om03830@om03830n:~> libreoffice
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGFPE (0x8) at pc=0x00007f4f99c3f6cf, pid=9229, tid=139981333080512
#
# JRE version: OpenJDK Runtime Environment (7.0_45-b31) (build 1.7.0_45-b31)
# Java VM: OpenJDK 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libqt-mt.so.3+0x5916cf]  QMutexPool::get(void*)+0x1f
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/jvm-9229/hs_error.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
Comment 10 Julien Nabet 2013-11-25 21:16:43 UTC
Olivier: thank you for your quick feedback! :-) I put it at New since there's a bt.

Lionel/Petr: Base (+perhaps OpenSuse specific problem?), any idea?
Comment 11 Julien Nabet 2014-06-01 12:37:29 UTC
Olivier: for the test, could you give a try to 4.2.4 LO version? (with a brand new LO profile if possible)
FYI last 4.1 version is 4.1.6 and there won't be any new official LO 4.1.X version.
Comment 12 Julien Nabet 2014-08-27 21:32:34 UTC
Olivier: any update with 4.2.6 or 4.3.0 (for the test)?
Comment 13 Marina Latini (SUSE) 2014-10-01 08:21:48 UTC
Confirmed on LibO:
* Version: 4.4.0.0.alpha0+
* Build ID: 65277f994ae25d930c15aebba0ed19f8de0abba1
* TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-09-29_19:47:20
* OS: Ubuntu 14.04.1 x86_64
Comment 14 Marina Latini (SUSE) 2014-10-01 08:24:43 UTC
Created attachment 107168 [details]
Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20

Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20
Comment 15 Marina Latini (SUSE) 2014-10-01 08:29:02 UTC
According to "Prioritizing_Bugs_Flowchart":

set importance from medium, normal to highest blocker
Comment 16 Lionel Elie Mamane 2014-10-01 09:12:58 UTC
(In reply to comment #14)
> Created attachment 107168 [details]
> Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20
> 
> Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20

This does not look like a backtrace... It looks like a gzipped tar of a single gzipped file that contains only binary nulls?
Comment 17 Marina Latini (SUSE) 2014-10-01 09:52:17 UTC
Created attachment 107171 [details]
Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20

Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20
Comment 18 Lionel Elie Mamane 2014-10-01 10:11:21 UTC
(In reply to comment #17)
> Created attachment 107171 [details]
> Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20
> 
> Backtrace LibO 4.4.0.0.alpha0+ daily build 2014-09-29_19:47:20

You get a different backtrace than Olivier Musson. Also a backtrace that will happen only in a debug build. You get an unexpected thrown exception, something which is just ignored in a release build, but leads to an abort in a debug build. The interesting information would be which exception thrown from where.

Well, anyway, I still cannot reproduce (in my debug build).

Also, I now realise that the original reporter said the problem 'disappeared' in a newer version, so actually your (Marina) abort may be a completely different problem and unrelated.
Comment 19 Marina Latini (SUSE) 2014-10-01 10:43:09 UTC
(In reply to comment #18)

> 
> Also, I now realise that the original reporter said the problem
> 'disappeared' in a newer version, so actually your (Marina) abort may be a
> completely different problem and unrelated.

Ok, can I provide other informations for my crash? How can I help?
Maybe I can fill a new bug report. Let me know.

Best,
Marina
Comment 20 Julien Nabet 2014-10-01 18:03:18 UTC
Marina: do you reproduce this with LO package provided by ppa (see https://launchpad.net/~libreoffice/+archive/ubuntu/ppa)?

Indeed, I think .deb or .rpm provided by TDF is more for Linux distrib packagers to manage dependecies. Since I'm neither a LO expert nor a distrib package, it's just an idea, not a sure thing :-)
Comment 21 tommy27 2014-10-02 06:56:34 UTC
@Lionel
should Marina open a separate report for her issue or should we keep the discussion here?
Comment 22 Lionel Elie Mamane 2014-10-02 07:09:44 UTC
(In reply to Julien Nabet from comment #20)
> Marina: do you reproduce this with LO package provided by ppa (see
> https://launchpad.net/~libreoffice/+archive/ubuntu/ppa)?

I expect those are not debug (--enable-dbgutil) builds, so the exact problem she reported will not happen; the same actions could theoretically still lead to a different crash/abort, though.

(In reply to tommy27 from comment #21)
> should Marina open a separate report for her issue or should we keep the
> discussion here?

Let's fork it into a different bug.
Comment 23 Lionel Elie Mamane 2014-10-02 07:11:33 UTC
Since original reporter (in comment 6) wrote that the problem is "gone in OpenSuSE 13.1", I'm going to close this one under presumption that it is fixed, although we don't know in which version exactly.