Download it now!
Bug 84586 - missing core05 .deb package in build
Summary: missing core05 .deb package in build
Status: RESOLVED DUPLICATE of bug 82288
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All Linux (All)
: highest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on: 71648
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-02 07:18 UTC by Lionel Elie Mamane
Modified: 2014-10-05 06:30 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
log unhandled exceptions to stderr (818 bytes, patch)
2014-10-02 07:29 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2014-10-02 07:18:08 UTC
+++ This bug was initially created as a clone of Bug #71648 +++

Problem description: 

Steps to reproduce:
1. Start LibreOffice
2. Choose Menu -> Options
3. LibreOffice Base -> Connections or -> Databases

Current behavior:
A debug build of LibreOffice aborts in some circumstances, but this is not universally reproducible.

Reported (by Marina Latini) on:
* Version: 4.4.0.0.alpha0+
* Build ID: 65277f994ae25d930c15aebba0ed19f8de0abba1
* TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-09-29_19:47:20
* OS: Ubuntu 14.04.1 x86_64

A backtrace is in attachment 107171 [details].

The abort happens in drivermanager::OSDBCDriverManager::createEnumeration because an unexpected exception is thrown.

What we need to determine:
 * What exception is thrown from where, but is unexpected in
   drivermanager::OSDBCDriverManager::createEnumeration?
 * Under what circumstances does that happen?
Comment 1 Lionel Elie Mamane 2014-10-02 07:29:14 UTC
(In reply to Marina Latina from comment #19 from bug 71648)
> Ok, can I provide other informations for my crash?

If you find a set of circumstances where it does abort and a set of circumstances where it does not abort (other than debug build / non-debug build), that would be helpful.

If you know how to use a debugger, then breaking into drivermanager::OSDBCDriverManager::createEnumeration, then breaking on thrown exceptions would by very helpful, with the goal to determine which exception thrown from anywhere leads to this abort.

If you don't know how to use a debugger, but know how to recompile LibreOffice yourself, it would be very helpful to apply the attached patch, which will give (some, but not all) information on the problematic exception.
Comment 2 Lionel Elie Mamane 2014-10-02 07:29:56 UTC
Created attachment 107217 [details]
log unhandled exceptions to stderr
Comment 3 Julien Nabet 2014-10-02 07:32:06 UTC
Lionel: what about pushing this patch on master. It could potentially be helpful for other cases, couldn't it?
Comment 4 Julien Nabet 2014-10-02 07:40:12 UTC
Marina: here's a very helpful link to build LO:
https://wiki.documentfoundation.org/Development/BuildingOnLinux
Comment 5 Lionel Elie Mamane 2014-10-02 07:43:13 UTC
Marina, are you absolutely positively sure that you are using:
* Build ID: 65277f994ae25d930c15aebba0ed19f8de0abba1
* TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-09-29_19:47:20
* OS: Ubuntu 14.04.1 x86_64

I ask because:

1) The backtrace you gave, as far as I know,
   can only happen in a debug build,
   but this is not a debug build.

2) I tried to install it myself, from
   http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@46-TDF/2014-09-29_19.47.20/
   but it is missing one .deb file,
   namely lodevbasis4.4-core05_4.4.0.0.alpha0-1_amd64.deb
   It has core01, 2, 3, 4, 6, 7, but not 5.

   So, how did you install it?


Maybe you are using some build of

* TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master

(note the added "-dbg")?
Comment 6 Lionel Elie Mamane 2014-10-02 07:47:09 UTC
Actually, I tried to run that build in spite of the installation errors. It starts, but I get the same abort indeed, with the following message on stderr

terminate called after throwing an instance of 'com::sun::star::loader::CannotActivateFactoryException'

I presume this is because of the missing files from the "core05" package.
Comment 7 Lionel Elie Mamane 2014-10-02 07:56:36 UTC
For complete clarity, Marina, it is not useful anymore to do any of the things I asked for. This is most probably due to the missing files in the install. You should have had installation errors when you installed this LibreOffice build? (Or maybe you have an older "core05" package installed from another build.)
Comment 8 Marina Latini (SUSE) 2014-10-02 08:53:49 UTC
(In reply to Lionel Elie Mamane from comment #7)
> For complete clarity, Marina, it is not useful anymore to do any of the
> things I asked for. This is most probably due to the missing files in the
> install. You should have had installation errors when you installed this
> LibreOffice build? (Or maybe you have an older "core05" package installed
> from another build.)

Hi All,

I'm using the daily build installed in parallel [0].
Downloaded the .deb package from here: [1] 

I'm using a fresh user profile (changing the user path in "bootstraprc").
You're right, core05 is missing but with the parallel install I use dpkg-deb so this isn't a real installation (with setup errors). ;)

[0]: https://wiki.documentfoundation.org/Installing_in_parallel
[1]: http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@46-TDF/current/

Maybe the problem is the missing core05 archive.
Comment 9 reporter_of_bugs 2014-10-05 06:03:35 UTC
The missing core05 deb has been reported here:
https://bugs.freedesktop.org/show_bug.cgi?id=82288
Comment 10 Lionel Elie Mamane 2014-10-05 06:30:10 UTC

*** This bug has been marked as a duplicate of bug 82288 ***