Bug 82288 - deb / rpm master installation builds broken because of missing core05 package
Summary: deb / rpm master installation builds broken because of missing core05 package
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All Linux (All)
: high major
Assignee: Christian Lohmaier
URL:
Whiteboard: target:4.4.0
Keywords:
: 84586 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-07 09:19 UTC by Riccardo Magliocchetti
Modified: 2014-10-11 08:38 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Magliocchetti 2014-08-07 09:19:19 UTC
Different issue but master build are broken for both deb and rpm for missing core05 package:

$ tar tvzf master~2014-07-31_12.19.47_LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_deb.tar.gz  | grep core
-rw-r--r-- root/root      8102 2014-07-31 18:10 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_deb/DEBS/lodevbasis4.4-core07_4.4.0.0.alpha0-1_i386.deb
-rw-r--r-- root/root  86286118 2014-07-31 18:12 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_deb/DEBS/lodevbasis4.4-core04_4.4.0.0.alpha0-1_i386.deb
-rw-r--r-- root/root  28695738 2014-07-31 18:09 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_deb/DEBS/lodevbasis4.4-core01_4.4.0.0.alpha0-1_i386.deb
-rw-r--r-- root/root     83512 2014-07-31 18:12 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_deb/DEBS/lodevbasis4.4-core02_4.4.0.0.alpha0-1_i386.deb
-rw-r--r-- root/root    291032 2014-07-31 18:12 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_deb/DEBS/lodevbasis4.4-core03_4.4.0.0.alpha0-1_i386.deb
-rw-r--r-- root/root   7216384 2014-07-31 18:12 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_deb/DEBS/lodevbasis4.4-core06_4.4.0.0.alpha0-1_i386.deb

$ tar tvzf master~2014-07-31_12.19.47_LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_rpm.tar.gz  | grep core
-rw-rw-r-- root/root      9141 2014-07-31 18:06 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_rpm/RPMS/lodevbasis4.4-core07-4.4.0.0.alpha0-1.i586.rpm
-rw-rw-r-- root/root     86455 2014-07-31 18:09 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_rpm/RPMS/lodevbasis4.4-core02-4.4.0.0.alpha0-1.i586.rpm
-rw-rw-r-- root/root  28704047 2014-07-31 18:06 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_rpm/RPMS/lodevbasis4.4-core01-4.4.0.0.alpha0-1.i586.rpm
-rw-rw-r-- root/root  86284726 2014-07-31 18:08 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_rpm/RPMS/lodevbasis4.4-core04-4.4.0.0.alpha0-1.i586.rpm
-rw-rw-r-- root/root    298321 2014-07-31 18:06 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_rpm/RPMS/lodevbasis4.4-core03-4.4.0.0.alpha0-1.i586.rpm
-rw-rw-r-- root/root   7345145 2014-07-31 18:06 LibreOfficeDev_4.4.0.0.alpha0_Linux_x86_rpm/RPMS/lodevbasis4.4-core06-4.4.0.0.alpha0-1.i586.rpm

4.3.1 is fine in this respects:

$ tar tvzf libreoffice-4-3~2014-07-30_10.54.10_LibreOfficeDev_4.3.1.0.0_Linux_x86_deb.tar.gz | grep core
-rw-r--r-- root/root     76652 2014-07-30 15:09 LibreOfficeDev_4.3.1.0.0_Linux_x86_deb/DEBS/lodevbasis4.3-core02_4.3.1.0.0-1_i386.deb
-rw-r--r-- root/root    275176 2014-07-30 15:10 LibreOfficeDev_4.3.1.0.0_Linux_x86_deb/DEBS/lodevbasis4.3-core05_4.3.1.0.0-1_i386.deb
-rw-r--r-- root/root  85730066 2014-07-30 15:09 LibreOfficeDev_4.3.1.0.0_Linux_x86_deb/DEBS/lodevbasis4.3-core04_4.3.1.0.0-1_i386.deb
-rw-r--r-- root/root    290938 2014-07-30 15:09 LibreOfficeDev_4.3.1.0.0_Linux_x86_deb/DEBS/lodevbasis4.3-core03_4.3.1.0.0-1_i386.deb
-rw-r--r-- root/root   7193894 2014-07-30 15:10 LibreOfficeDev_4.3.1.0.0_Linux_x86_deb/DEBS/lodevbasis4.3-core06_4.3.1.0.0-1_i386.deb
-rw-r--r-- root/root  28721154 2014-07-30 15:09 LibreOfficeDev_4.3.1.0.0_Linux_x86_deb/DEBS/lodevbasis4.3-core01_4.3.1.0.0-1_i386.deb
-rw-r--r-- root/root      8102 2014-07-30 15:10 LibreOfficeDev_4.3.1.0.0_Linux_x86_deb/DEBS/lodevbasis4.3-core07_4.3.1.0.0-1_i386.deb

Both the oldest and newest master build tarballs are broken.
Comment 1 Owen Genat (retired) 2014-08-12 02:45:05 UTC
Confirmed. Daily Linux-rpm_deb-x86_64@46-TDF build for 2014-07-19 contained core05 package, but currently available Linux-rpm_deb-x86_64@46-TDF builds (I have checked 2014-07-29, 2014-08-08, and 2014-08-10) omit this package. Status set to NEW. Platform set to All as original report indicates x86. Summary amended for clarity.
Comment 2 Christian 2014-08-27 10:00:18 UTC
same applies to (on CentOS7)
master~2014-08-21_00.23.28_LibreOfficeDev_4.4.0.0.alpha0_Linux_x86-64_rpm.tar.gz

I checked master~2014-08-21_00.23.28_LibreOfficeDev_4.4.0.0.alpha0_Linux_x86-64_rpm.tar.gz
master~2014-08-21_23.23.16_LibreOfficeDev_4.4.0.0.alpha0_Linux_x86-64_rpm.tar.gz
master~2014-08-23_22.03.46_LibreOfficeDev_4.4.0.0.alpha0_Linux_x86-64_rpm.tar.gz
master~2014-08-26_09.48.30_LibreOfficeDev_4.4.0.0.alpha0_Linux_x86-64_rpm.tar.gz
Comment 3 Owen Genat (retired) 2014-09-06 06:05:02 UTC
Linux-rpm_deb-x86_64@46-TDF builds for 2014-08-18, 2014-08-21, 2014-08-26, 2014-08-30, and 2014-09-05 all omit this package.
Comment 4 Vera 2014-09-20 19:11:56 UTC
The package core05 is still missing from these DEBs.

Linux-rpm_deb-x86_64@46-TDF:
2014-09-06 07.16.00
2014-09-06 23.02.10
2014-09-09 10.24.58
2014-09-09 04.59.25
2014-09-09 23.17.41
2014-09-11 00.32.52
2014-09-16 17.33.21
2014-09-17 10.09.07
Comment 5 Lionel Elie Mamane 2014-10-05 06:30:10 UTC
*** Bug 84586 has been marked as a duplicate of this bug. ***
Comment 6 Jean-Baptiste Faure 2014-10-05 07:39:50 UTC
Same problem with my own builds if I try to generate packages under Ubuntu 14.04 x86-64.

Best regards. JBF
Comment 7 Julien Nabet 2014-10-05 11:04:07 UTC
Putting Build system/gbuild experts (see https://wiki.documentfoundation.org/FindTheExpert) in cc + increase a bit the importance since the impact of this problem.
Comment 8 Michael Stahl (CIB) 2014-10-06 09:10:40 UTC
let's CC some people who may know something about epm...
Comment 9 Michael Stahl (CIB) 2014-10-06 09:12:54 UTC
(perhaps it would make sense to merge all these core* packages into one, probably the split exists only for hysteric reasons)
Comment 10 Björn Michaelsen 2014-10-06 09:45:03 UTC
(In reply to Michael Stahl from comment #9)
> (perhaps it would make sense to merge all these core* packages into one,
> probably the split exists only for hysteric reasons)

I seem to remember that the hysteric reason was Windows not being able to have packages of arbitrary size back in the days. That might or might not have changed.
Comment 11 Christian Lohmaier 2014-10-07 21:24:55 UTC
for some reason (I'm too lazy too debug), the files that are meant to end up in the core05 package are packaged into the core04 one. Likely a minor syntax error somewhere.

working on merging all the -core0x packages into a single "-core" one anyway.

distro-packages might have to adapt slightly
Comment 12 Adolfo Jayme 2014-10-08 01:44:58 UTC
Christian Lohmaier committed a patch related to this issue. It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6759a98f7b28e99b885aef9e78aed6bc225af992

fdo#82288 merge core01-core07 packages into just one
Comment 13 Jean-Baptiste Faure 2014-10-11 08:38:25 UTC
Verified with my onw build of 4.4 alpha generating deb packages. Installation OK on a different machine.

Thank you very much.

Best regards. JBF