Bug 71690 - TDF Site: Download -> System Requirements: Add Windows Server 2008 R2, 2012 and Windows 8.1 + Windows 10 + FreeBSD
Summary: TDF Site: Download -> System Requirements: Add Windows Server 2008 R2, 2012 a...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: high normal
Assignee: Not Assigned
URL: http://www.libreoffice.org/get-help/s...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-17 09:24 UTC by Gerry
Modified: 2015-08-27 20:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2013-11-17 09:24:26 UTC
In the system requirements of the download section at LibreOffice.org (http://www.libreoffice.org/download/system-requirements/), there are three systems missing that should be added (provided LO runs on these systems which seems to be the case when searching this question on the internet):

Windows Server 2008 R2
Windows Server 2012
Windows 8.1

FreeBSD -> Additionally, it could be mentioned in the system requirements that LibreOffice runs on FreeBSD and is available in its repositories as a package: 
http://www.freebsd.org/applications.html
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/desktop-summary.html
Comment 1 Thomas van der Meulen 2013-11-17 12:37:07 UTC
Yes they are missing. I will set the bug to new
Comment 2 Gerry 2013-11-20 07:52:52 UTC
With regards to FreeBSD the wording on the system requirements page could be:


*FreeBSD*
"LibreOffice runs on FreeBSD and is available as package in the standard FreeBSD repositories (http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/desktop-summary.html). This is the suggested way to install LibreOffice on FreeBSD. There is no other community-supplied LibreOffice installer provided."
Comment 3 QA Administrators 2015-04-19 03:21:00 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 4 Gerry 2015-04-23 15:35:58 UTC
Bug still existing. Information has not yet been added to http://www.libreoffice.org/get-help/system-requirements/. 2015-04-23
Comment 5 Gerry 2015-07-04 07:49:01 UTC
Please also add Windows 10 to the system requirements page.

It is funny that this trivial bug is around for such a long time. It seems that no one looks at bugs for component "WWW"
Comment 6 Gerry 2015-08-12 06:42:01 UTC
Please add Windows 10 to the system requirements. LO 5 has been explicitly advertised with Windows 10 compatibility, but it is not listed there. Thanks!
Comment 7 Dennis Roczek 2015-08-15 21:15:40 UTC
setting to highest now.
Comment 8 Gerry 2015-08-19 09:15:21 UTC
If someone starts working on this, he/she could also add NetBSD to the notes: http://pkgsrc.se/misc/libreoffice
Comment 9 Robinson Tryon (qubit) 2015-08-27 13:54:07 UTC
(In reply to Gerry from comment #5)
> Please also add Windows 10 to the system requirements page.
> 

Win8 and win10 now appear on the sys req page. I'm not sure about the other OSes being considered under the label 'supported', so let me do more research there.

Dropping priority -> high, as all known supported OSes now listed.
Comment 10 Robinson Tryon (qubit) 2015-08-27 20:29:54 UTC
(In reply to Robinson Tryon (qubit) from comment #9)
> Win8 and win10 now appear on the sys req page. I'm not sure about the other
> OSes being considered under the label 'supported', so let me do more
> research there.

Okay, System Requirements page updated to list all OSes for which we provide TDF builds, including a mention of the Android Impress Remote. For other OSes (incl. FreeBSD), I've pointed to information on the TDF wiki. 

I think we're all done here, right?
Status -> RESOLVED FIXED