Download it now!
Bug 71698 - Writer 4.1.3 not able to read certain documents
Summary: Writer 4.1.3 not able to read certain documents
Status: RESOLVED DUPLICATE of bug 71450
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-11-17 13:47 UTC by Friedmann Bruno
Modified: 2013-11-17 15:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Crashing file under 4.1x (116.91 KB, application/vnd.oasis.opendocument.text)
2013-11-17 13:47 UTC, Friedmann Bruno
Details
working file non ok point placed at the end (167.69 KB, application/vnd.oasis.opendocument.text)
2013-11-17 13:48 UTC, Friedmann Bruno
Details
2 destroyed point alone works (115.40 KB, application/vnd.oasis.opendocument.text)
2013-11-17 13:48 UTC, Friedmann Bruno
Details
Two ok point alone work also (119.52 KB, application/vnd.oasis.opendocument.text)
2013-11-17 13:49 UTC, Friedmann Bruno
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Friedmann Bruno 2013-11-17 13:47:23 UTC
Created attachment 89354 [details]
Crashing file under 4.1x

Write 4.1.3 is not able to open certain documents, which are valid with 3.6 and 4.0x version.
Tested with openSUSE build & pure Windows Loo version

In attachement you will find several files : 
We use a template, which are edited by programs. This has worked for years now, and still work with any version < 4.1x loo.

Description : NOK are point measurements where the point is declared destroyed, a remark (In French) is added (Point détruit)

1-NOK-1-OK_KABOOM.odt this file finish with error read input file in 4.1.3
The destroyed point is followed by normal ok point

1-OK-2-NOK.odt this file work and contain almost same data but the NOK Point (destroyed remark) are placed on the last page.

2-NOK.odt this file works, two non okay points are inside

2-OK.odt this file works, two non destroyed (ok) points are inside.
Comment 1 Friedmann Bruno 2013-11-17 13:48:13 UTC
Created attachment 89355 [details]
working file non ok point placed at the end
Comment 2 Friedmann Bruno 2013-11-17 13:48:58 UTC
Created attachment 89356 [details]
2 destroyed point alone works
Comment 3 Friedmann Bruno 2013-11-17 13:49:32 UTC
Created attachment 89357 [details]
Two ok point alone work also
Comment 4 Cor Nouws 2013-11-17 14:18:50 UTC
Hi Friedmann,

Thanks for the report and the sample files.
I am not looking at details of what opens fine and not, but confirm that 71698_1-NOK-1-OK_KABOOM.odt indeed does not open in 4.1.3.2.
Working on Ubuntu 32 bits.

File opens in 4.1.2.x but not in 4.1.3.1 and 4.1.3.2

Cheers,
Cor
Comment 5 Maxim Monastirsky 2013-11-17 15:07:24 UTC
Reverting http://cgit.freedesktop.org/libreoffice/core/commit/?id=b69d152cfa1da868ba960345d72ba78f9f8e1b35 fixes the bug.

*** This bug has been marked as a duplicate of bug 71450 ***