Bug 71705 - copy and paste does not work out of third party software (TVGenial)
Summary: copy and paste does not work out of third party software (TVGenial)
Status: RESOLVED DUPLICATE of bug 66217
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-17 16:34 UTC by c.cavada
Modified: 2016-09-19 16:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Export from Software to Notepad to LibreOffice (179.62 KB, image/jpeg)
2013-11-17 16:34 UTC, c.cavada
Details
Export from software to notepad to LibO (179.62 KB, image/jpeg)
2013-11-17 16:52 UTC, c.cavada
Details

Note You need to log in before you can comment on or make changes to this bug.
Description c.cavada 2013-11-17 16:34:51 UTC
Created attachment 89367 [details]
Export from Software to Notepad to LibreOffice

Not an nativ speaker - sorry

I am using the Software TVGenial (http://www.tvgenial.com/). The Software shows descriptions of an film, after I doubleclick on any program a new window opens. There I have the option to copy the text to the clipboard or to Email the description of the chosen film.

Pasting into LibreOffice cuts the text and does not contain the content of the clipboard. The text is incomplete compare to the clipboard.

Pasting from the software to the clipboard (notepad) gives the full text (plain). Pasting then from the notepad cuts the text again in LibreOffice.

Choosing the option to send an email with the description does work with Thunderbird - there appears an new email with the full text.

I am in contact with the support of "TVGenial" and they would be interessted on the interface that is needed to deliver data to LibreOffice.

Any suggestions would be appreciated
Thx in advanbce
CC
Comment 1 c.cavada 2013-11-17 16:52:17 UTC
Created attachment 89370 [details]
Export from software to notepad to LibO
Comment 2 retired 2014-01-03 13:41:52 UTC
Interesting bug. Guess we need some developer input to move this forward. As soon as that is available would be great if cavada could forward that to the TVGenial devs.

Does this problem persist with LO 4.2.0.1 http://www.libreoffice.org/download/pre-releases/
Comment 3 c.cavada 2014-01-03 14:38:33 UTC
I am still in contact with the TVGenial support and will forward results to them.

After sucessfull install of LO 4.2.0.1 (and the helppack of this release...) the results are the same. The pasted clipboard content is not complete, while the pasting into the notepad delivers me the complete text :(
Comment 4 Dennis Roczek 2014-01-27 22:20:53 UTC

*** This bug has been marked as a duplicate of bug 66217 ***
Comment 5 Maxim Monastirsky 2014-01-28 13:26:14 UTC
@c.cavada: Does it happen even if you click on the drop-down button of the 'paste' button and choose 'unformatted text'?

@Roczek: Why do you think that it's a duplicate of Bug 66217? While both are about the clipboard handling (and I guess both are about handling of the HTML clipboard format), but it might be a completely different problem?
Comment 6 c.cavada 2014-01-30 03:12:13 UTC
@ Maxim - same as described, text gets cut off.

@Roczek - solved is nothing. And an duplicated of 66217? I will look there then...
Comment 7 Robinson Tryon (qubit) 2015-12-18 10:24:13 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2016-09-19 16:48:15 UTC Comment hidden (obsolete)