Download it now!
Bug 71707 - FORMATTING: Conditional Formatting is incorrectly linked on copied sheet
Summary: FORMATTING: Conditional Formatting is incorrectly linked on copied sheet
Status: CLOSED DUPLICATE of bug 61946
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-17 17:23 UTC by oudeis69
Modified: 2013-11-23 12:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
simple calc document showing the erroneous behaviour. (7.33 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-11-17 17:23 UTC, oudeis69
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oudeis69 2013-11-17 17:23:48 UTC
Created attachment 89371 [details]
simple calc document showing the erroneous behaviour.

Problem description: 
 
The conditional formatting (formula type) of source sheet is copied to the destination sheet, but the contents of the conditional formatting formula still refers to the source sheet. 

Steps to reproduce:
1. create a simple conditional formatting on Sheet1.A1: =$C1="x" 
2. copy Sheet1 as Sheet2 -> conditional formatting on Sheet2.A1: =$C1="x"
3. insert a column B in Sheet1
4. conditional formatting on Sheet2.A1 is now WRONG: =$D1="x"

Current behavior:
The copied sheet conditional formatting formulas refer to the wrong sheet 

Expected behavior:
The copied sheet conditional formatting formulas must refer to the copied sheet and not to the source shett.

              
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 m.a.riosv 2013-11-17 22:12:54 UTC
Hi oudeis69, thanks for reporting.

Are you sure, there are not both sheets selected when inserting the column?

I can not reproduce the issue if only Sheet1 is selected.
Comment 2 oudeis69 2013-11-18 06:36:15 UTC
The two sheets weren't selected. 
How can I be so sure? Easy: the (visible) contents of row C in sheet2 is *not* moved...
Comment 3 oudeis69 2013-11-18 06:49:40 UTC
My explanation (and description) of the bug was not clear enough...

The problem is with the conditional formatting only when using, e.g.:
  "Formula is" $C1="x"

My wordings were not "correct" in the bug submission...
Comment 4 Eike Rathke 2013-11-23 12:18:21 UTC
Fixed with bug 61946

*** This bug has been marked as a duplicate of bug 61946 ***