Bug 71783 - VIEWING: Nimbus Sans L font renders differently in master
Summary: VIEWING: Nimbus Sans L font renders differently in master
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha1
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-19 13:13 UTC by Dave Richards
Modified: 2014-04-16 17:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Green is LO 4.1 (correct), Red is LO 4.2 (wrong), Note the font (405.03 KB, image/png)
2013-11-19 13:13 UTC, Dave Richards
Details
Document seen in screenshot (458.76 KB, application/vnd.oasis.opendocument.text)
2013-11-19 13:13 UTC, Dave Richards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2013-11-19 13:13:16 UTC
Created attachment 89459 [details]
Green is LO 4.1 (correct), Red is LO 4.2 (wrong), Note the font

We have a document used heavily in our organization, which works perfectly in 4.1 and earlier but renders incorrectly in 4.2.  There is a frame in the middle with Nimbus Sans.  In 4.2 the font is squished together so that the letters touch, and the font itself looks very different.  We have many hundreds of this document on our network, so impact for us is great.

Will attach the document, along with screenshot.
Comment 1 Dave Richards 2013-11-19 13:13:47 UTC
Created attachment 89460 [details]
Document seen in screenshot
Comment 2 Dave Richards 2013-11-19 13:14:06 UTC
Only able to test on 64bit Linux.
Comment 3 m.a.riosv 2013-11-19 22:09:54 UTC
Hi Dave,

do you have the same scale in both? (Bottom right)
Comment 4 Dave Richards 2013-11-20 12:37:00 UTC
The one of the right is zoomed in a bit more to make the font problem more evident.  In the frame, you can see the characters are squished together and have no space between them.  This frame section also does not print correctly with characters completely overlapped.
Comment 5 Maxim Monastirsky 2013-11-20 15:04:40 UTC
Reproducible under Fedora 19 (64-bit). LO 4.1.3.2 & master build with Build ID: 9491ca3f64bd44a6a8e63f7d2eae02164f792258.

Reproducible with every document that uses Nimbus Sans L font, so we have easy reproduction steps:
1) Open a new writer document in 4.1.3
2) Choose Nimbus Sans L font
3) Write 'Hello World'
4) Repeat the same with a master build
5) Compare results

It looks like in 4.1.3 LO uses the 'Regular' style, while in master it uses 'Condensed'. Bug 50855 might be related.
Comment 6 Dave Richards 2014-04-16 17:23:50 UTC
FOund this to be an issue with the font in OpenSuse 11.2.  Upgrading the font fixed the issue.  Closing.