Download it now!
Bug 71869 - Other: Printing with PostScript-driver produces wrong kerning and missing letters near to f-letters
Summary: Other: Printing with PostScript-driver produces wrong kerning and missing let...
Status: RESOLVED DUPLICATE of bug 67802
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-21 10:38 UTC by bugs.libreoffice.11.2013
Modified: 2013-11-21 22:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugs.libreoffice.11.2013 2013-11-21 10:38:03 UTC
Problem description: 

Steps to reproduce:
1. Open / Create an writer-document which has many f-letters.
2. Print (tried at 2 identical Lexmark C782dn laser printers) with Postscript-driver.

Current behavior:

Kerning right from / at f-letters is wrong (some interferre, some produce missing letters (Of ce instead of Office)

Expected behavior:

Normal Kerning and no missing letters. Works when using PDF-driver.
              
Operating System: openSUSE
Version: 4.1.3.2 release
Comment 1 Björgvin Ragnarsson 2013-11-21 11:26:17 UTC
The standard print job format on linux is PDF and this printer prefers PDF jobs over postscript according to this PPD which I guess you are using: http://www.openprinting.org/ppd-o-matic.php?driver=Postscript&printer=Lexmark-C782dn&show=1

You should verify that the CUPS isn't actually converting the postscript output from libreoffice to PDF before it sends it to the printer. This conversion process could be the source the kerning problems and missing letters.
Comment 2 bugs.libreoffice.11.2013 2013-11-21 11:42:43 UTC
I think my bug does match this: https://bugs.freedesktop.org/show_bug.cgi?id=67802

@Björgvin Ragnarsson:

Thanks for your reply. Printing with PDF driver does output lower quality, so that's no solution for us.

Can I do anything (configure, send more information, ...) to help resolving this bug?
Comment 3 Khaled Hosny 2013-11-21 21:24:09 UTC

*** This bug has been marked as a duplicate of bug 67802 ***
Comment 4 Björgvin Ragnarsson 2013-11-21 22:19:49 UTC
I can suggest you possible workarounds but cannot help you further:

Select a PDF backend to a printer, go to options and check Print to file.
Then print and open the PDF with a PDF reader. If the PDF is not blurry you can convert it to postscript before printing.

Another possibility is to remove

*cupsFilter:	"application/vnd.cups-pdf 0 foomatic-rip"

from the printer driver (PPD) you use and only leave in

*cupsFilter:	"application/vnd.cups-postscript 100 foomatic-rip"

Then configure the printer in libreoffice as PDF printer and use it. If this is done, printing subsystem (CUPS) will convert the PDF output to postscript before sending it to the printer.