Bug 71884 - Error starting 4.2RC1 (32-bit) LibreOffice on OS X
Summary: Error starting 4.2RC1 (32-bit) LibreOffice on OS X
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta1
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.0.beta2:OSX
Keywords:
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-11-21 16:45 UTC by Martin Srebotnjak
Modified: 2015-02-13 11:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2013-11-21 16:45:01 UTC
I installed 4.2.0beta1 on OS X and upon starting it I get the followin pop-up window:
"LibreOfficeDev.app" is damaged and can't be opened. You should move it to the Trash.

I remember seeing that with 4.2.0alpha, but then I reinstalled it and it worked. I tried deleting, reinstalling several times, but beta1 does not start properly on my system.
Comment 1 Martin Srebotnjak 2013-11-21 16:46:48 UTC
FYI, I have OS X 10.9.
Comment 2 retired 2013-11-22 14:17:28 UTC
Hey Miles,

could you please try the latest nightly? Works for me on 10.9.

And re-open this bug should that not be the case.

http://dev-builds.libreoffice.org/daily/master/MacOSX-x86@49-TDF/current/

master~2013-11-22_07.09.14_LibreOfficeDev_4.3.0.0.alpha0_MacOS_x86.dmg
Comment 3 Martin Srebotnjak 2013-11-22 14:50:48 UTC
Yes, it works.

But it took a lot of time to open the first time, maybe because it is alpha, I do not know. The icon just jumped down below. Then I killed it and it again took some time but it finally prompted to allow running it as it was downloaded from Internet.
All subsequent starts were fast.

Also, this is for another bug report, the "developer is not identified" so one must visit the Security settings on OS X 10.9 to allow running it.
Comment 4 retired 2013-11-22 23:12:31 UTC
Yes, stable releases should be properly signed I think so won’t be an issue then.
Comment 5 Martin Srebotnjak 2013-11-23 14:02:01 UTC
Will beta1 be respun with this fix? Otherwise this is shoud remain a blocker for OSX.
Comment 6 Martin Srebotnjak 2013-12-05 18:28:47 UTC
Tried LO 4.2.0 Beta 2 on my system and the problem is back, same messagge.
This is a blocker for beta2, I guess.
Comment 7 Jean Weber 2013-12-06 04:23:24 UTC
I am also getting that error message on OS X 10.9.
Comment 8 Jean Weber 2013-12-06 04:24:04 UTC
(In reply to comment #7)
> I am also getting that error message on OS X 10.9.

Should have said: using Beta2.
Comment 9 Robinson Tryon (qubit) 2013-12-06 10:24:22 UTC
Adding whiteboard tag for repro status.
Comment 10 Christian Lohmaier 2013-12-06 12:17:14 UTC
builds for beta2 have been replaced by unsigned ones, this will avoid the "is damaged" problem, but to run it you have to use open from the context-menu (instead of double-clicking) to get the option to open it despite not being signed.
Comment 11 Jean Weber 2013-12-20 05:21:00 UTC
I'm having the same problem with the RC1: "damaged and can't be opened". OS X 10.9
Comment 12 Jean Weber 2013-12-20 21:51:48 UTC
My problem was with the 32-bit version, which is what the download page suggested and what I have been using for previous LO versions. When I tried the 64-bit version of 4.2.0.1, it opened as it should.
Comment 13 retired 2013-12-20 23:41:40 UTC
updated the title for 4.2RC2 and 32-bit
Comment 14 Michael Meeks 2014-01-23 15:13:02 UTC
Should be fixed in RC3 - can you try from: http://dev-builds.libreoffice.org/pre-releases/mac/x86/
Comment 15 retired 2014-01-23 21:50:14 UTC
Can't help testing since I never ran into the issue. Both 32bit and 64bit OSX builds of 4.2RC3 do mount and install as expected here.
Comment 16 Martin Srebotnjak 2014-01-23 23:24:13 UTC
It seems to work now, cannot reproduce anymore.
Comment 17 Martin Srebotnjak 2015-02-12 23:02:17 UTC
I must unfortunately reopen this bug - this happened again with 4.4.1RC1, it must be a regression of some kind!

Please do check, this is a blocker for OSX.

The only difference with the primary report is that now it is a 64-bit build (as there are no 32-bit OS X builds anymore).

Should I change the version number (to 4.4.1RC1) and hardware (to 64-bit) in the bug report?
Comment 18 Robinson Tryon (qubit) 2015-02-12 23:11:44 UTC
(In reply to miles from comment #17)
> I must unfortunately reopen this bug - this happened again with 4.4.1RC1, it
> must be a regression of some kind!

I don't see a specific fix mentioned for this bug in the comments below, and this was never marked as independently confirmed (Although perhaps Jean in comment 7 was suggesting as much?), so correct status should be UNCONFIRMED.

> 
> Please do check, this is a blocker for OSX.
> 
> The only difference with the primary report is that now it is a 64-bit build
> (as there are no 32-bit OS X builds anymore).
> 
> Should I change the version number (to 4.4.1RC1) and hardware (to 64-bit) in
> the bug report?

If it's exactly the same issue, then potentially this bug report will be helpful (especially as existing commenters might be helpful for repro). If several variables have changed (architecture, etc..), then please file a new bug report.
Comment 19 Martin Srebotnjak 2015-02-12 23:19:02 UTC
Well, Robinson, I do not know if it is the same bug from the developer's standpoint, it sure looks the same bug from the user's one (the error message is exactly the same and renders the installed LO441RC1 unusable).
Comment 20 Robinson Tryon (qubit) 2015-02-12 23:26:27 UTC
(In reply to miles from comment #19)
> Well, Robinson, I do not know if it is the same bug from the developer's
> standpoint, it sure looks the same bug from the user's one (the error
> message is exactly the same and renders the installed LO441RC1 unusable).

Sounds good -- let's go with this bug report :-)

Thankfully for us, the total number of combinations of OSX hardware is quite limited, so hopefully we can get repro on this issue.

Miles: What version of OSX are you currently running?
Comment 21 Robinson Tryon (qubit) 2015-02-12 23:27:32 UTC
(Updating hardware and Summary)
Comment 22 Martin Srebotnjak 2015-02-12 23:36:58 UTC
I currently use Yosemite (10.10.2).
Comment 23 m.a.riosv 2015-02-13 01:19:32 UTC
Have you tried resetting the user profile?

https://wiki.documentfoundation.org/UserProfile
Comment 24 Martin Srebotnjak 2015-02-13 02:56:44 UTC
Yes, even after deleting/renaming the existing profile it still does not want to start.
Comment 25 Michael Stahl (CIB) 2015-02-13 09:32:50 UTC
this bug was about 32-bit 4.2 builds and now it suddenly talks about 64-bit 3.3 builds? this is very confusing, please file a *new* bug!

sigh... could we *please* have a check in bugzilla that random users are not allowed to re-open bugs resolved years ago?
Comment 26 Martin Srebotnjak 2015-02-13 09:35:44 UTC
Random user? Which country do you live in so I can sue you?
Comment 27 Martin Srebotnjak 2015-02-13 09:38:24 UTC
This bug report is reopened because the symptoms are the same even if the OSX architecture changed - it is believed for now that this is a regression from the first bug.
Since some commenters have mentioned it has been fixed for 4.2 it gives an opportunity to find that fix and see if with 4.4 there were some unwanted changes in that part of code that could trigger a regression.
Comment 28 Michael Stahl (CIB) 2015-02-13 11:36:34 UTC
apologies for any excessive grumpiness in my previous comment - it was caused by looking at bugzilla before breakfast, which is clearly something i should not be doing.

(if you re-open a 4.2 most-annoying bug like this one then a mail is sent to the developer mailing list)

probably the 4.4 issue is about the known digital signature problem that came up not via any change in LO but by OS X 10.9.5 suddenly changing the rules; that should be fixed for 4.4.1.2, see bug 84352.