Bug 71941 - LO uses formatting from adjacent cell when it should not
Summary: LO uses formatting from adjacent cell when it should not
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-23 16:01 UTC by Aprax
Modified: 2013-11-24 14:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aprax 2013-11-23 16:01:42 UTC
Can't provide a screenshot, this happens haphazardly.

If the cell to the left has a 'not white' background and a value is entered into the current cell which has a white background, upon pressing enter, the current cell's background colour now matches the cell to the left.

It's also happened that the type is copied, i.e. if entering a time into a column formatted as Time = hh:mm and the column to the left is formatted as Date = yyyy-mm-dd nn then the entered value of 13:22 is formatted as a Date which is really wrong since no one uses "13:32" as a Date, and the system date format is h:m:s.
Comment 1 Cor Nouws 2013-11-23 19:59:48 UTC
Hi Aprax,

thanks for the issue.
I can confirm this.

Simple test:
 A1
 Ctrl+B
 type Foo, Enter
 A1 is bold, focus on A2
 type Again, Enter
 A2 is bold too..

Should test when this started ..

Cheers,
Cor
Comment 2 m.a.riosv 2013-11-23 20:03:48 UTC
Hi Aprax, thanks for reporting.

But I think, deactivating the option in Menu/Tools/Options/LibreOffice calc/General - Expand formatting, must solve what you think is a bug.

Changed status to resolved notabug.

Please if you are not agree reopen it.
Comment 3 Cor Nouws 2013-11-23 21:54:18 UTC
(In reply to comment #2)

> But I think, deactivating the option in Menu/Tools/Options/LibreOffice
> calc/General - Expand formatting, must solve what you think is a bug.

:) Apparently an option that was never active before?
Anyway, new to me.

thanks Mariosv,
Comment 4 m.a.riosv 2013-11-23 22:10:38 UTC
Maybe someone changed default without notice, at least I have not seen.
Comment 5 Aprax 2013-11-24 12:38:22 UTC
The fix, to untick, is not intuitive, very not intuitive, it's buried so deep in the config.

It definitely should be unticked by default.

It may be useful for some people but really I can't think of any time when I'd want that. If I insert new columns, I format them myself if they need to be. I don't want the program to assume the new column has the same characteristics as the one to the left. 
Example: I have two 'time' columns followed by a text column and decide to insert a column to calculate the number of days between two 'date' columns elsewhere, the new column should be 'number' but extended formatting makes it 'time'. Which has to be changed either way, but is frustrating when it's initially made 'time'.

I guess the 'fix' is to change the default for brand new installs but what about us folks that 'update over' existing config that has this ticked? It's definitely a PITA, confusing at least, and if everybody has to 'report a bug' to find this answer, that's a lot of time wasted.

If this config was added as a new 'feature' and defaulted to ticked, that was a mistake, and one with serious consequences to the reputation of the product. 
Any new feature needs to be tested in the context of the number of users that will benefit from and want and understand it. My reaction was that 'someone broke LO Calc' (and I muttered a few words that I won't repeat :)

How could this be 'fixed' for the unwashed masses that have this ticked but don't have any idea why their lovable LO is now their unlovable LO?

The Status option NOTABUG should be changed to BIGBOOBOOSORRY   :)

J
Comment 6 m.a.riosv 2013-11-24 13:31:39 UTC
Resetting the user profile is:

Disable by default
  Versión 4.0.6.2 (ID de compilación: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)
  Version: 4.1.4.0.0+ Build ID: d6ee64b75581cbeb92534271ee6f4e87f07aa5c
  Versión: 4.2.0.0.beta1 Id. compilación: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7

Maybe if it was changed, it was reverted at some point.

If you want verify it in your exact version, reset your user profile:
https://wiki.documentfoundation.org/UserProfile
Comment 7 Aprax 2013-11-24 14:12:45 UTC
After some thought I now think it might have been a "greedy" change that I made when I upgraded from V 3xxxx to V4.0xxxx during a review of configuration settings.
To rephrase: 
I saw it was 'extended' ==> 'more' ==> 'GOOD to have MORE' ==> 'I want ALL GOOD THINGS', 
so..... I ticked to box unaware of what was about to befall me, because...

because I didn't do anything for quite some time that would have made me think "I just change a formatting option, maybe I should revert it and see if the 'bad things' go away.

A bit like mines in a mine field, planted a long time ago, now forgotten until of course you step on one....

I'll apologize now, and say thanks for the explanation, it worked, I'm happy again :)

J

PS add a status option for 'USERBOOBOO' :) and I'll click it myself.