Bug 71957 - StartCenter: single click or double-click to open a recent file should be consistent with the OS file manager
Summary: StartCenter: single click or double-click to open a recent file should be con...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta1
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2013-11-24 08:32 UTC by Jean-Baptiste Faure
Modified: 2014-10-26 17:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2013-11-24 08:32:46 UTC
The choice to open a recent file with a single click or a double click should not be hard coded in LibreOffice but taken from the File Manager configuration
For example, if I configured Nautilus to use a double click, it is not consistent to use a single click in LibreOffice. 

Another possibility is to make this choice configurable.

Best regards. JBF
Comment 1 Emir Sarı (away) 2013-11-24 10:07:50 UTC
+1 from me. I always find myself double clicking on Start Center recent items, and it is very non-native. 

If it is going to be there should be some mouse-on-hover background or something that implies single click. 

Recent files area should mimick the file manager, if possible use the same api or services, not rediscover the America.
Comment 2 narayanaras 2013-12-29 12:29:13 UTC
Also, while the document is opening, the mouse pointer should turn into an "hourglass" (wait) shape.
Comment 3 V Stuart Foote 2014-01-04 17:41:58 UTC
Mouse over effect ( http://cgit.freedesktop.org/libreoffice/core/commit/?id=f655b23d57f234c0e92255302353f2a0a3fad487 ) resolves immediate issues.

Adjusting remaining request for behavior consistent with OS file management to be an enhancement.
Comment 4 Urmas 2014-07-05 01:17:58 UTC
There is no reason to select items in recent files pane.

They should be opened by the single click, unconditionally.
Comment 5 V Stuart Foote 2014-07-05 12:56:58 UTC
(In reply to comment #4)
> There is no reason to select items in recent files pane.
> 
> They should be opened by the single click, unconditionally.

Would disagree, in that from a user perspective, following what their OS norm is really is the correct behavior, i.e. a single or a double click.  

But it does add dev complexity in forcing the GTK+ UI Widgets to follow the OS or DTE behavior.
Comment 6 Urmas 2014-07-05 18:16:07 UTC
It is a god-damned menu. No one will double-click menus.
Comment 7 V Stuart Foote 2014-07-05 18:28:06 UTC
(In reply to comment #6)
> It is a god-damned menu. No one will double-click menus.

Huh? Are you sure you are thinking of the correct elements?

The Start Center recent items panel provides a GUI representation of the 25 recently used documents. Each is a GTK+ UI Widget object instantiation that responds to mouse and key board actions.

The same list of recent documents IS available as a menu list from the File -> Recent Documents menu. Those can be navigated with mouse (single click) or key board movement (U,D,L,R) to select and <return> to open.
Comment 8 Adolfo Jayme 2014-10-26 14:14:30 UTC
The GNOME HIG [1] says:

“… Double click should not be used, since it is undiscoverable, and translates poorly to touch input.”

> Recent files area should mimick the file manager, […] not rediscover the America.

No. We are not a file manager, and we shouldn’t pretend we are one. Double-clicks were introduced in file managers because a single-click would only highlight (select) an element, and taking that selecting-versus-executing dichotomy to the Start Center only adds unnecessary usage complexity and slows down the simple operation of opening something.

Also, double-click is an obsolete action pattern, which is also difficult to reproduce for many people without fine motor skills.

[1]: https://developer.gnome.org/hig/3.14/pointer-and-touch-input.html.en
Comment 9 Jean-Baptiste Faure 2014-10-26 14:51:08 UTC
Today, I tend to agree with Adolfo Jaime (comment #8) because it seems that the behavior of the StartCenter changed since I reported this issue. If I remember well at that time, if you moved the mouse cursor over a document thumbnail, it was not clear that the document was select. It not the case anymore.

That said, considering that our users are mainly using MS-Windows OS, it is not obvious for me if Gnome HIG is relevant.

Best regards. JBF
Comment 10 Adolfo Jayme 2014-10-26 17:10:48 UTC
> […] considering that our users are mainly using MS-Windows OS, it is
> not obvious for me if Gnome HIG is relevant.

Well, given that we’ve redesigned all our dialogs based off it, I’d say it’s pretty relevant ;-)