Bug 71981 - FILEOPEN: Opening file using ssh
Summary: FILEOPEN: Opening file using ssh
Status: RESOLVED DUPLICATE of bug 67527
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-25 09:46 UTC by Lenicodesbois
Modified: 2013-11-25 11:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lenicodesbois 2013-11-25 09:46:53 UTC
Problem description: 
Mounting an ssh volume in Nautilus, it is impossible to open a file on the server.
The apps answers "file damaged, would you like Open office to repare it?"... and of course if yes is answered, it is not working.

The only way we found to work is to copy the file on a local folder, then work on the file, and finaly copy the modified file on the remote folder...

Steps to reproduce:
1. Place a file on a server
2. Mount the folder using ssh
3. Open the remote file with Nautilus.

Current behavior:

Expected behavior: should open the file, and save the file.

              
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 Lenicodesbois 2013-11-25 09:48:35 UTC
Libre Office and not Open office...
I am confused...
Comment 2 Maxim Monastirsky 2013-11-25 10:13:34 UTC
@Lenicodesbois: Hi, thank you for reporting this bug. Could you please answer the following questions:

- Which Ubuntu version do you use?
- What the source of LibreOffice? PPA or manually downloaded from http://www.libreoffice.org/download?
- How do you mount ssh? from nautilus or from command line?
- Does opening /usr/share/applications/libreoffice-writer (for example, for writer documents) and commenting\removing the line 'X-GIO-NoFuse=true' makes any difference?
Comment 3 Lenicodesbois 2013-11-25 10:48:39 UTC
Hi, thanks for the support.

Here are the answers of the questions:

- Which Ubuntu version do you use?
>12.04 LTS, we plan to switch in 14.04 LTS

- What the source of LibreOffice? PPA or manually downloaded from http://www.libreoffice.org/download?
> we use the PPA as the version is 1:4.1.3~rc2-0ubuntu1~precise1~ppa1

- How do you mount ssh? from nautilus or from command line?
> yes we mount ssh via nautilus (1:3.4.2-0ubuntu8), "connect to a server"

- Does opening /usr/share/applications/libreoffice-writer (for example, for writer documents) and commenting\removing the line 'X-GIO-NoFuse=true' makes any difference?
> YES! its working now! 
I ve commented the line in /usr/share/applications/libreoffice-calc.desktop.
Do I have to modify in all the libreoffice-* files ?
Comment 4 Lenicodesbois 2013-11-25 10:52:26 UTC
It seems to be solved here:
http://ask.libreoffice.org/en/question/23021/solved-open-ods-or-odt-files-from-a-smb-share-throws-damaged-file-error/

by using
"sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/share/applications/libreoffice-*"

Right?
Comment 5 Maxim Monastirsky 2013-11-25 11:06:21 UTC
OK, it's a known bug with glib package in Ubuntu 12.04, filled as https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/1214352.

(In reply to comment #4)
> It seems to be solved here:
> http://ask.libreoffice.org/en/question/23021/solved-open-ods-or-odt-files-
> from-a-smb-share-throws-damaged-file-error/
> 
> by using
> "sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/'
> /usr/share/applications/libreoffice-*"
> 
> Right?
Yes, it's the same as commenting manually.

(If this workaround will cause you problems, you could also try to install the official build from http://www.libreoffice.org/download, but then make sure to also install 'libgnomevfs2-0' and 'liborbit2' packages.)

*** This bug has been marked as a duplicate of bug 67527 ***
Comment 6 Lenicodesbois 2013-11-25 11:11:13 UTC
Super, thanks a lot.