Bug Hunting Session
Bug 72015 - FORMATTING: Error formatting fractions
Summary: FORMATTING: Error formatting fractions
Status: CLOSED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-26 01:46 UTC by fcannon
Modified: 2013-11-26 04:36 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fcannon 2013-11-26 01:46:13 UTC
Downloaded and installed 4.1.3.2. 
Results below.

Regards
FCannon  

     A    "Displayed as":
1  1 1/8 (1.125) all is good
2 1 ¼    (1 1/4) all is not so good        
3  1 1/8
4 1 ¼
    
Operating System: Windows 7
Version: 4.1.3.2 release
Comment 1 Ady 2013-11-26 04:35:55 UTC
fcannon,

What you just described is not a bug.

Since no 'fraction' format was set first for those cells, the result you described is as expected.

If you first format the cells as fraction before inserting the data, then they are shown as fractions (not with decimals), except for your "1 1/4", which is still interpreted as text.

I would agree that "1 1/4" should remain as 'fraction' when the cell has already been formatted as 'fraction'. You already reported such behavior in bug #71974.

Since the initial format you describe in this report is different from what you describe in bug #71974, this is not exactly a duplicate.

Since the behavior described here is as expected, I am closing this report as NOTABUG.

If you have something to add regarding this issue, please do it in bug #71974
 at https://bugs.freedesktop.org/show_bug.cgi?id=71974 where you can log-in too.

Regards,
Ady.