Bug 72028 - FILEOPEN: Opening PDF in Writer adds a space after each letter
Summary: FILEOPEN: Opening PDF in Writer adds a space after each letter
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-26 11:05 UTC by Gerry
Modified: 2014-04-19 07:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
simple-writer-file.odt (28.26 KB, application/vnd.oasis.opendocument.text)
2013-11-26 11:06 UTC, Gerry
Details
simple-writer-file.pdf (27.00 KB, application/pdf)
2013-11-26 11:06 UTC, Gerry
Details
Screenshot-of-imported-PDF-in-Writer.png (328.96 KB, image/png)
2013-11-26 11:07 UTC, Gerry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2013-11-26 11:05:09 UTC
LibreOffice 4.2 brings the new feature that PDF files can also be imported in Writer (previously only in Draw). This is a really cool feature, but unfortunately does not work suffiently at all. The imported PDF is absolutely not producing something one can actually work with.

How to reproduce:
(1) Please have a look at attachment 1: Simple-Writer-file.odt and attachment 2: Simple-Writer-file.pdf. The text is absolutely basic: Normal text in a few paragraphs without any further formatting.

(2) Now import the PDF in attachment 2 in Writer by "File" -> "Open" (here select the filter "PDF - Portable Document Format (Writer)" from the long list. 

(3)  The result of the imported PDF in Writer looks terrible. It is attached as attachment 3: Screenshot-of-imported-PDF-in-Writer.png
Comment 1 Gerry 2013-11-26 11:06:31 UTC
Created attachment 89827 [details]
simple-writer-file.odt
Comment 2 Gerry 2013-11-26 11:06:49 UTC
Created attachment 89828 [details]
simple-writer-file.pdf
Comment 3 Gerry 2013-11-26 11:07:42 UTC
Created attachment 89829 [details]
Screenshot-of-imported-PDF-in-Writer.png
Comment 4 Maxim Monastirsky 2013-11-26 11:29:41 UTC
Hi,

(In reply to comment #0)
> LibreOffice 4.2 brings the new feature that PDF files can also be imported
> in Writer (previously only in Draw).
As far as I know, there is no such new feature in 4.2. I can see the same feature in 4.1.3.2.

> The imported PDF is
> absolutely not producing something one can actually work with.
Indeed. It's the same filter that used to import to Draw, just placing the content in Writer document instead of Draw document.

If you want we can turn this bug into a feature request for a real Writer filter. What do you think?
Comment 5 Gerry 2013-11-26 14:17:17 UTC
Hi Maxim, thanks. Now I realize that it was already in 4.1.x. Very interesting, as it was not announced (but maybe because it is not working properly).

I think you have an idea how to convert this into a feature request for a real Writer filter. I think this is a good idea. Feel free to go ahead.
Comment 6 Maxim Monastirsky 2013-11-26 19:57:56 UTC
@Gerry: Sorry, I was not right regarding your bug report. After opening the attached pdf with Draw & Writer I could see that it's indeed a Writer bug. When you open the pdf in Draw, it's hard to edit (due to many textboxes), but at least it *looks* good. When you open in Writer, there is a space added after each letter.

I'm able to reproduce it also with 4.1.3.2 under Fedora 19 (64-bit), so I'll set the version respectively.

BTW the feature request for a real Writer filter is already exists - Bug 32249.

Sorry again.
Comment 7 Gerry 2014-04-11 18:22:42 UTC
Problem still exists in:

Version: 4.2.3.3
Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0
Comment 8 Gerry 2014-04-16 10:23:21 UTC
Is this a duplicate of bug 35143?
Comment 9 Samuel Mehrbrodt (CIB) 2014-04-16 10:42:22 UTC
Try and see if your problem persists in current builds.
Comment 10 Gerry 2014-04-17 08:45:30 UTC
The problem is still there in a quite recent LibreOffice nightly build.
PDF import in Draw is fine, but import in Writer is broken.

Version: 4.3.0.0.alpha0+
Build ID: 615f6aa293a6da90da94e6e78828198ffbc0ca5e
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-08_01:30:26
Comment 11 vvort 2014-04-18 06:38:12 UTC
I have ported some Draw import changes to Writer.
But I want to note one thing: Writer import feature presently way behind Draw's one.
Because Writer import is hidden and not developers nor testers don't know about it.
https://gerrit.libreoffice.org/9091
Comment 14 Gerry 2014-04-19 07:23:39 UTC
@vvort: Thanks a lot!