Bug 72053 - Subscript indices located far away from the variable they belong to
Summary: Subscript indices located far away from the variable they belong to
Status: RESOLVED DUPLICATE of bug 47352
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: IA64 (Itanium) Windows (All)
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-26 21:44 UTC by delta_III
Modified: 2013-12-22 16:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Difference in subscript index location dependent on usage in normal text or in equation (1.33 MB, image/x-ms-bmp)
2013-11-26 21:44 UTC, delta_III
Details
LibreOffice Writer file corresponding to the attached screenshot showing the false positioning of the subscript indizes (19.77 KB, application/vnd.oasis.opendocument.text)
2013-11-27 19:38 UTC, delta_III
Details
Comparison: correct location of subscript indizes in MS Word (39.15 KB, image/bmp)
2013-12-01 15:48 UTC, delta_III
Details

Note You need to log in before you can comment on or make changes to this bug.
Description delta_III 2013-11-26 21:44:04 UTC
Created attachment 89868 [details]
Difference in subscript index location dependent on usage in normal text or in equation

I'm using LibreOffice to write my thesis and therefore using the Equation editor extensively. In the latest version, as well as in the version i had installed before, some of the subscript indizes in the equations are located way too far from the variable they belong to, so that it looks like they are in front of the next variable following in the equation. My professor unfortunately mentioned this as one of th items he considers annoying while reading the thesis. Until now i could not find any solution for this problem, since the editor only allows to adjust the height of the indices as well as its vertical location, but not the horizontal spacing. Changing the equation from an italic to a normal font style reduces the problem slightly, but as a matter of fact equations should be written italic in scientific papers. I added a screenshot where this problem becomes obvious. Nevertheless, writing the same variable and subscript index in the normal text in italic style is displayed correct.
Comment 1 m.a.riosv 2013-11-27 02:03:23 UTC
Hi delta, thanks for reporting.

Please if you attach a file with the sample, maybe someone can take a look at it.
Comment 2 delta_III 2013-11-27 19:38:20 UTC
Created attachment 89915 [details]
LibreOffice Writer file corresponding to the attached screenshot showing the false positioning of the subscript indizes

As requested shows the attached file the positioning problem of the subscript indizes in the Equation Editor. The text passage corresponds to the previously uploaded screenshot and explanation. It clearly shows the positioning problem by comparing identical variables with their respective subscript indizes in the equation and in normal text.
Comment 3 m.a.riosv 2013-11-28 00:45:33 UTC
Hi delta, IMO it is not wrong, in this position it is aligned with a superscript for the function.
f^{(0)}_{(1)}

Maybe a request for enhancement.
Comment 4 delta_III 2013-12-01 15:48:11 UTC
Created attachment 90054 [details]
Comparison: correct location of subscript indizes in MS Word

The picture shows how the subscript indizes are positioned in MS Word. Unlike in LibreOffice, MS Word is moving the subscript indizes left towards the variable they belong to, thus not letting the distance increase too much. It seems logical that in case of italic variables the indizes should not be vertically aligned anymore, but should include a horizontal offset.
Comment 5 delta_III 2013-12-01 15:53:36 UTC
Of course the way the formulas in LibreOffice's Equation Editor are visualized is still mathematically correct, but it is nevertheless an "imperfection". Indeed an obvious imperfection which can also be easily identified by a person who does not have a technical background.
Comment 6 m.a.riosv 2013-12-01 17:48:05 UTC
As workaround, seems a bit closer using ƒ code 0192 without italic instead of f.

{"ƒ" ^{0}_{INST,TX}} over
{f ^{0}_{INST,TX}}

a lot of fonts have it, and it is possible to select a font in math.
Comment 7 Owen Genat (retired) 2013-12-09 10:35:15 UTC
This would appear to be a duplicate of bug 47352. The issue is largely with the use of italics for variables and the gap this creates between the base of the variable and the following subscript.
Comment 8 Joel Madero 2013-12-22 16:58:32 UTC
Agreed - this is a duplicate.

*** This bug has been marked as a duplicate of bug 47352 ***