Bug 72054 - VIEWING: Wrong colors in table cells in 4.1 from 4.0
Summary: VIEWING: Wrong colors in table cells in 4.1 from 4.0
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Björn Michaelsen
URL:
Whiteboard: BSA
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2013-11-26 22:10 UTC by Jabari
Modified: 2015-12-17 07:33 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original document. In Table 2, the cell for number 529 in column 17 changed it color scheme from version 4.0.x to 4.1.x (49.90 KB, application/vnd.oasis.opendocument.text)
2013-11-26 22:13 UTC, Jabari
Details
PDF of original file created in 4.0.x. Notice in Table 2, cell with 529 is (should be) different color than 469 (171.34 KB, application/pdf)
2013-11-26 22:15 UTC, Jabari
Details
This is pdf made with 4.1.x which shows Table 2 cell for 529 has same (wrong) color scheme as 469. (167.80 KB, application/pdf)
2013-11-26 22:17 UTC, Jabari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jabari 2013-11-26 22:10:04 UTC
Problem description: 

In a document created with Writer 4.0 I had a table with numbers with different colors in the cells to differentiate the data. I noticed when I created a revised pdf of the same file in 4.1.x the color for one cell was different than it was in 4.0.x.

Steps to reproduce:
1. On a PCLOS Live CD which has LO 4.0.3 on it I opened the file and it showed the original color for the table cell in question. I then created a pdf and saved it to a USB drive and compared it to the version created from the same file in 4.1.x, which showed a different color theme.

Current behavior:
For the original table cell colors have different color in 4.1.0

Expected behavior:
The table cell colors in 4.1.x should be the same as in 4.0.x.

              
Operating System: All
Version: 4.1.0.4 release
Last worked in: 4.0.0.3 release
Comment 1 Jabari 2013-11-26 22:13:16 UTC
Created attachment 89869 [details]
Original document. In Table 2, the cell for number 529 in column 17 changed it color scheme from version 4.0.x to 4.1.x
Comment 2 Jabari 2013-11-26 22:15:48 UTC
Created attachment 89870 [details]
PDF of original file created in 4.0.x. Notice in Table 2, cell with 529 is (should be) different color than 469
Comment 3 Jabari 2013-11-26 22:17:41 UTC
Created attachment 89871 [details]
This is pdf made with 4.1.x which shows Table 2 cell for 529 has same (wrong) color scheme as 469.
Comment 4 retired 2013-12-31 11:54:22 UTC
I can confirm that the number 469 529 do have the same color in 4.2.0.1
Since I do not have any LO 4.0.x version here to test I take your work that the colors there indeed show those two numbers in different color.

Setting to NEW.
Comment 5 Björn Michaelsen 2014-03-16 00:45:44 UTC
# bad: [25428b1e953636f74986622c5df614f04c150ed1] source-hash-cb4e009c4539c535108021934e545194b35cad9d
# good: [f0f6c65eb764f0303f59c58d320e9b0d5a894377] source-hash-4b9740b4ec3987e1d4d2ad6d20b4dcf996a4fa2e
git bisect start 'latest' 'oldest'
# bad: [a72833796a7e527d9efc9ca6d8fe9b579e469105] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
git bisect bad a72833796a7e527d9efc9ca6d8fe9b579e469105
# bad: [4300c48268179afe8db66410fad04436183407cd] source-hash-753310b7db6a36aeaae36cef3bfca970e9310569
git bisect bad 4300c48268179afe8db66410fad04436183407cd
# good: [280c5141ea58e6b50f7d46546a9c52891225eeff] source-hash-ba446dd58a4ad324d242afcd5b28d3b4dff5a881
git bisect good 280c5141ea58e6b50f7d46546a9c52891225eeff
# bad: [8734d0269629a270d9e97cb5176bcc6b76338a54] source-hash-07352f07ce40ef40e9b73fd05aa4f9c5eac38290
git bisect bad 8734d0269629a270d9e97cb5176bcc6b76338a54
# good: [b42797d9346abe9681bf36768258d309b83d17da] source-hash-ee53857e984fea54b7dc08b99079b38766f0b796
git bisect good b42797d9346abe9681bf36768258d309b83d17da
# good: [e0d6b9193ada7bf1103848f0ee7e5c1839ed106f] source-hash-6bacf391710c8ebaa42b083dc14fb13cff48cd16
git bisect good e0d6b9193ada7bf1103848f0ee7e5c1839ed106f
# good: [15d98338f8ab2152b731553ffcda84cb7902ee67] source-hash-68c3dfc3119a50ee9c9c6d65f4c656637152bbad
git bisect good 15d98338f8ab2152b731553ffcda84cb7902ee67
# first bad commit: [8734d0269629a270d9e97cb5176bcc6b76338a54] source-hash-07352f07ce40ef40e9b73fd05aa4f9c5eac38290

So a regression, which was introduced in this range:
http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=68c3dfc3119a50ee9c9c6d65f4c656637152bbad..07352f07ce40ef40e9b73fd05aa4f9c5eac38290
Comment 6 Björn Michaelsen 2014-03-17 12:39:26 UTC
So this is caused by 77e21bb36a2cdaaa0f4049dee0d45c5b2325c6e9 which fixes fdo#61993 which seems sensible. So the color in 4.0 was wrong, the color in 4.1 is better.

Thus, unless ODF would specify something conflicting about this, resolving this as NOTABUG.
Comment 7 Robinson Tryon (qubit) 2015-12-17 07:33:41 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]