Download it now!
Bug 72077 - FILESAVE: Crash after trying to "save [file] as" - Reproduceable
Summary: FILESAVE: Crash after trying to "save [file] as" - Reproduceable
Status: RESOLVED DUPLICATE of bug 69002
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-27 16:25 UTC by unknown77
Modified: 2013-11-29 08:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Terminal-Output (427 bytes, text/plain)
2013-11-27 16:25 UTC, unknown77
Details

Note You need to log in before you can comment on or make changes to this bug.
Description unknown77 2013-11-27 16:25:22 UTC
Created attachment 89904 [details]
Terminal-Output

I am running Arch-Linux with this version of LibreOffice:
Version: 4.1.3.2
Build ID: 4.1.3.2 Arch Linux build-1
My DE is KDE.

Since this version it happens regularly that LibreOffice-Writer chrashes after I try to save any document. It only appears, when I run "save as" saving a existing file is not an isssue. I can reproduce the error easily.

1. Open a new document.
2. Save [File] as.
3. Abort an retry steps one an two until it chrases
Comment 1 Julien Nabet 2013-11-27 19:25:45 UTC
Do you open and save on local hard disk or other? (network, usb, etc)
Comment 2 unknown77 2013-11-27 22:23:23 UTC
(In reply to comment #1)
> Do you open and save on local hard disk or other? (network, usb, etc)

Local.

Regards.
Comment 3 billhook 2013-11-27 22:34:01 UTC
Your instructions are a little unclear.

Do you actually save the file? Or do you press cancel in the file save dialog? (you say you "Abort and retry")

Also, how many times do you generally have to retry steps 1 and 2 before it crashes? 1? 2? 5? 10?

Also, what format are you saving the file in? .odt?
Comment 4 unknown77 2013-11-27 23:13:07 UTC
> Do you actually save the file? Or do you press cancel in the file save
> dialog? (you say you "Abort and retry")

Yes, this is a little unclear, sorry. It happens in a normal working-flow. When I am writing a few lines sometimes it chrashes, when I hit "save as". I crashes before I choose anything (like location, file-name. etc.).

Because it happened a few times and I lost my text, I startet LibreOffice by terminal to see some error-messages. I opened LibreOffice and hit "save as". Everything was ok. So I aborted an retried to provoke an error.  

> Also, how many times do you generally have to retry steps 1 and 2 before it
> crashes? 1? 2? 5? 10?

This is different. Sometimes it happens the first time, sometimes I need up to 7 
attempts. 

> Also, what format are you saving the file in? .odt?

Yes, "odt".
Comment 5 unknown77 2013-11-27 23:38:20 UTC
Ok. I know what the problem was. I had to use an older version of open-jdk, because of a webapplication that my company uses which is based on java and not compatible with newer versions of open-jdk (greater than jre7-openjdk-7.u9_2.3.4-1-x86_64). Therefore I was forced to keep this older version. 

After upgrading I was not able to reproduce the error with LibreOffice.

Luckily the actual version of open-jdk is working with my company's web-app.
Comment 6 Julien Nabet 2013-11-28 06:33:50 UTC
Ok thank you for your feedback unknown77, I put it as WFM.
Comment 7 Mark Riehm 2013-11-29 00:04:11 UTC
I'm not sure if I can post here since it was marked as resolved, but I experience this exact same issue, and I am completely up-to-date with the latest version of OpenJDK.

Actually, this issue has been happening to me for a long time (6 months?), but I've never filed a bug report before, and I'm just now fed up enough to diagnose it.

My experience of the bug is as follows:
1. Open the 'save as' dialog box (I seem to remember it happening with other file dialog boxes like 'insert image', but it's not happening right now)
2. Wait for about 5 seconds, maybe traversing some folders, but never actually save.
3. In these 5 seconds, the dialog box responsiveness slows down considerably.
4. Libreoffice crashes with no visible error, unless you are running it from the console.

Like the previous poster said, it doesn't happen every time, I seem to have about the same frequency he stated.

It may be relevant that I am also running Arch Linux with KDE, and I have the 'libreoffice-kde' integration package from the arch repositories installed. However, I seem to remember experiencing the same problem on Windows 7/8 as well, but I haven't done that in a while and I don't have log files for it.

Here is the entire output from the console of one run of the program that crashed:

************************************************************************************************

$ /usr/lib/libreoffice/program/oosplash --writer

Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
"/org/freedesktop/UDisks2/drives/XXXXXXXXX" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/XXXXXXXXX" : property "Drive" does not exist 
LibreOffice(8901) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf! 
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fceda2e8150, pid=8901, tid=140526722520896
#
# JRE version: OpenJDK Runtime Environment (7.0_45-b31) (build 1.7.0_45-b31)
# Java VM: OpenJDK 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libQtGui.so.4+0x366150]  QTransform::type() const+0x0
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/XXXXX/hs_err_pid8901.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
#

[error occurred during error reporting , id 0xb]

*******************************************************************************************************

As you can see, it says that it recorded an error log with more information. It is very long, but if you would like me to post it, then I will.

Thanks for your help.
Comment 8 Julien Nabet 2013-11-29 06:30:49 UTC
Mark: which LO version do you have?
For the test, could you try again without libreoffice-kde ?
Could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try?

Finally, if you still reproduce this, could you retrieve backtrace by following this link? (please put the backtrace in a file and attach the file to the bugtracker)
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 9 Mark Riehm 2013-11-29 07:53:12 UTC
Thanks Julien, when I removed the 'libreoffice-kde4' package, the crashes seemed to stop. For the record, I can't completely confirm it is fixed since it was intermittent in the first place, but it's fixed as far as I can tell.

If the bug is caused by that package, is this bug still applicable to this Bugzilla? The package seems to indicate that this is an official plugin and cites 'www.libreoffice.org' as the upstream source, but let me know if I should be filing this report with someone else instead.

It seems that the only file the package provides is:
'/usr/lib/libreoffice/program/libvclplug_kde4lo.so'

My Libreoffice version is 4.1.3.2
Comment 10 Maxim Monastirsky 2013-11-29 08:43:34 UTC

*** This bug has been marked as a duplicate of bug 69002 ***