Download it now!
Bug 72083 - Copying content with an image to the clipboard doesn't include it in the HTML data
Summary: Copying content with an image to the clipboard doesn't include it in the HTML...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-27 19:21 UTC by Alfonso Martínez de Lizarrondo
Modified: 2014-05-18 17:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alfonso Martínez de Lizarrondo 2013-11-27 19:21:18 UTC
Problem description: 

Steps to reproduce:
1. Create a document with at least one image
2. Select that and press copy
3. Check the contents of the clipboard in the HTML format

Current behavior:
The image doesn't exists in the HTML

Expected behavior:
Put a reference to a local file like MS Word does. This way when using for example IE11, the image can be pasted into a WYSIWYG editor http://ie.microsoft.com/testdrive/browser/Editing_Paste_Image/

Besides IE11, other software might also want to use such references to local files like Outlook: https://bugs.freedesktop.org/show_bug.cgi?id=59236

If I copy the content from LibreOffice to MS Word, the image is lost, only the text is copied (I guess that MS prefers the HTML format because the RTF version in the clipboard includes the image according to the clipboard inspector)



              
Operating System: Windows 7
Version: unspecified
Comment 1 tommy27 2014-05-18 06:18:01 UTC
please specify which LibO version are you using. 
moreover take a look at Bug 78801... are you reporting the same issue or your problem is different?
Comment 2 Alfonso Martínez de Lizarrondo 2014-05-18 17:44:02 UTC
I've tested right now with LibreOffice 4.2.4.2 (Windows) and it seems that it's working correctly. It embeds the image as a base64 URL and that way it works in all the browsers.

That other bug seems to be about pasting FROM a web page INTO libreOffice, so it was the opposite of this bug :-)