Bug 72151 - Calc hangs while formatting more than one cell to a RTL currency
Summary: Calc hangs while formatting more than one cell to a RTL currency
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta1
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 72470
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-29 13:34 UTC by Emir Sarı
Modified: 2014-02-07 21:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı 2013-11-29 13:34:26 UTC
Steps to reproduce:

1. Open Calc
2. Enter random values into two cells 
3. Select these cells
4. Right click and "Format Cells"
5. Click "Currency" tab and select an Arabic currency
6. Click "OK".

Expected behaviour:

Formatted cells with desired currency

Actual behaviour:

Calc hangs indefinitely.

FYI: If only one cell is selected, it works. But if more than one cell, it hangs.
Comment 1 Gerry 2013-11-30 08:16:38 UTC
I can reproduce the hang with LibreOffice 4.2Beta1 on Ubuntu 13.04. Setting to NEW. I also increase the severity to critical, because the only solution is to kill the LibreOffice process, data are lost.
Comment 2 Kohei Yoshida 2014-02-07 02:23:07 UTC
This could potentially be a duplicate of Bug 72470, where Calc hangs in presence of a cell that has mixed script types.  The fix for that just got backported this morning, so you may want to test a newer build from the 4.2.x branch and see if this is fixed.
Comment 3 m.a.riosv 2014-02-07 21:36:02 UTC
No issue now with:
Win7x64Ultimate
Version: 4.2.1.0.0+ Build ID: 63950ec72806489b41c2109f5c3840dcf22f4c6c
         TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-07_00:47:07

Certainly you are right Kohei, seems patches in bug 72470 has been solved the bug.

Change the status as duplicate of 72470

*** This bug has been marked as a duplicate of bug 72470 ***