Download it now!
Bug 72178 - Impress Freeze when EDITING partial table style via right-clic
Summary: Impress Freeze when EDITING partial table style via right-clic
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2013-11-30 17:42 UTC by Pierre C
Modified: 2019-11-24 14:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test file (142.95 KB, application/vnd.sun.xml.impress)
2013-11-30 17:42 UTC, Pierre C
Details
10.9 crashlog (65.92 KB, text/plain)
2013-12-02 11:58 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre C 2013-11-30 17:42:53 UTC
Created attachment 90034 [details]
test file

Step to reproduce :
1 - open attachment
2 - select a few cells
3 - right-clic on the selected cells et choose 'Edit Object Style' (or something like this "Editer le style de l'objet" in french)

--> Freeze 

You can't do a lot of things, but you can navigate to different slide, save your doc

Pierre
Comment 1 Gerry 2013-12-01 15:03:12 UTC
I can confirm this bug with LO 4.1.3.2 Build ID: 410m0(Build:2) (PPA) on Ubuntu 13.04.

As choffardet has described: The slide frame freezes, but not the rest of the application.
Comment 2 Pierre C 2013-12-01 15:20:04 UTC
As bug is confirmed under Ubuntu, changing platform to All
Comment 3 Pierre C 2013-12-01 15:28:23 UTC
I can confirm the bug under LO 3.5.7.2 / XP

AOo 4.0.1 can't open the file (Crash)
Comment 4 Pierre C 2013-12-01 15:37:58 UTC
Investigating further...

AOo Crash may be due to the use of Graphite font. Creating a new test file with only one table -> same freeze (OO401m4)

Same test with LO 4.1.4.1 -> same freeze, so it's not due to my particular file
Comment 5 retired 2013-12-02 11:55:27 UTC
Also confirmed in LO Version: 4.3.0.0.alpha0+
Build ID: a14cfd3d77104aee3e3c3d981a135161295197df
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-12-02_04:42:54

attaching OS X crashlog
Comment 6 retired 2013-12-02 11:58:34 UTC
It takes some clicking (just keep playing with the table in page 2 and marking stuff, right-click > Edit Style) eventually LO will crash.
Comment 7 retired 2013-12-02 11:58:56 UTC
Created attachment 90100 [details]
10.9 crashlog
Comment 8 Pierre C 2013-12-02 17:54:48 UTC
(In reply to comment #6)
> It takes some clicking (just keep playing with the table in page 2 and
> marking stuff, right-click > Edit Style) eventually LO will crash.

Be careful when playing with tables and LO 4.0.6 ; 4.1.x ; 4.2.x

It may be this bug : https://bugs.freedesktop.org/show_bug.cgi?id=71423

(Impress frequently crashes when editing tables in slides)

This bug (freeze of LO when right-clic for editing a partial table style) is an old-one. It was yet in LO 3.5.7.

I've been using this command, because of hazardous comportments of styles in impress tables. I've never had to use it before.
Comment 9 Jérôme Borme 2013-12-21 18:51:42 UTC
To get out of the "freeze," select a tool in the toolbar (for example the rectangle or the ellipsis tool), then click on the slide frame. It will not draw the ellipsis but it will un-select the table and get out of the Edit Style mode.
Comment 10 Pierre C 2014-12-16 20:56:51 UTC
Still present in 4.3.5.2
Comment 11 Pierre C 2015-04-19 14:39:59 UTC
Still freeze with LO 4.3.7.1 and LO master Win x64
Comment 12 QA Administrators 2016-09-20 09:32:43 UTC Comment hidden (obsolete)
Comment 13 Pierre C 2016-09-25 07:38:33 UTC
It still happens, but it seems easier to leave the freeze.

But as nothing happens when clicking "edit style" This option should simply be removed
Comment 14 Xisco Faulí 2017-09-29 08:52:16 UTC Comment hidden (obsolete)
Comment 15 Jérôme Borme 2017-09-29 09:49:08 UTC
Bug is still present with LO 5.4.0.3 on gentoo linux

Current description: When performing action "Edit style" on a partially selected table (as described in the original report), the UI becomes partly unresponsive. Typing at the keyboard will not add text to tables or existing text areas. However the rest of the UI works. Keyboard shortcuts work (tested Ctrl-O for Open). It is possible to use menus and toolbars. Using particular actions such as drawing a new text area clears the problem and lets the user restart using the keyboard for typing content.
Comment 16 QA Administrators 2018-09-30 02:47:31 UTC Comment hidden (obsolete)
Comment 17 Jérôme Borme 2018-09-30 13:44:26 UTC
Still present, LO 6.0.6.2
Comment 18 Timur 2019-11-24 14:41:50 UTC
I reproduced with LO 5.0.
No Edit style, just Table properties in new LO.
No crash in master 6.5+. I'll close as WFM.