Download it now!
Bug 72284 - FILESAVE: Crashes when trying to save a particular docx file
Summary: FILESAVE: Crashes when trying to save a particular docx file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA Confirmed:4.2.0.4:OSX (target:4.3.0)
Keywords:
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-12-03 20:45 UTC by Torben
Modified: 2014-03-21 22:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The template file that is refered to in the bug report and which I downloaded from Xero help website (25.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-12-03 20:45 UTC, Torben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torben 2013-12-03 20:45:05 UTC
Created attachment 90186 [details]
The template file that is refered to in the bug report and which I downloaded from Xero help website

Problem description: 

I use the Xero accounting website.  They allow you to define your own templates for invoices.  To do this you need to download one of their docx files and modify it to your needs.  After making my changes I try to save it, when the program just crashes.

Steps to reproduce:
1. Open the attached file "Packingslipandinvoicetemplate.docx"
2. Make any change to the document.
3. Save it, as a docx file

Current behavior:

When saving the document Write just crashes.  The main window just disappears.  On restart I get the option to recover the file, but it is at the same state as I opened it originally.

Expected behavior:

I expect the file to be saved correctly without Write crashing.
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 m.a.riosv 2013-12-04 01:26:02 UTC
Reproducible:
Win7x64Ultimate
Version: 4.1.4.1 Build ID: 414ce1317b94ce49e6044b84baf237918e9a659

Even saving as odt, open odt and save again as docx, crash.
Comment 2 surbhi.tongia 2013-12-11 13:55:06 UTC
File "Packingslipandinvoicetemplate.docx" is saved correctly without Write Crashing after making changes to the document.
Operating System: Windows 7
Verified on Build:libo-master~2013-12-11_02.11.28_LibreOfficeDev_4.3.0.0.alpha0_Win_x86.
Comment 3 Cor Nouws 2014-02-05 13:50:59 UTC
crashes in 4.2.0.4 too
Comment 4 sophie 2014-02-12 09:50:42 UTC
Changed importance to reflect the new policy - Sophie
Comment 5 retired 2014-02-12 10:09:49 UTC
Confirmed:4.2.0.4:OSX
Comment 6 Jorendc 2014-03-21 18:30:54 UTC
I can reproduce a crash using Windows 8.1 Version: 4.1.4.2 
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72

I can't reproduce a crash using Version: 4.3.0.0.alpha0+
Build ID: 514a6de4822523164ef66916198e36944a826db3
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-21_00:39:06

So marking as RESOLVED WORKSFORME (we don't know what patch fixed this issue, so not FIXED.

If you still can reproduce a crash using version 4.3.0-master versions, please feel free to reopen this bug.

Kind regards,
Joren
Comment 7 Norbert X 2014-03-21 18:46:12 UTC
Downloaded attachment, opened it, tried to save as docx - libreoffice crashed.
I use libreoffice 1:4.2.2~rc1-0ubuntu1~precise1 from ppa.
Comment 8 Jorendc 2014-03-21 19:23:32 UTC
(In reply to comment #7)
> Downloaded attachment, opened it, tried to save as docx - libreoffice
> crashed.
> I use libreoffice 1:4.2.2~rc1-0ubuntu1~precise1 from ppa.

Yes, and that's why I mentioned I used version 4.3.0, which is not released yet (will be released in Week 30 , Jul 21, 2014 - Jul 27, 2014 (see https://wiki.documentfoundation.org/ReleasePlan))

Please retest using version 4.3.0 which you can download here: http://dev-builds.libreoffice.org/daily/master/

The fix, we don't know, will probably not be backported to 4.2 branch.
Comment 9 Jean-Baptiste Faure 2014-03-21 22:04:46 UTC
No crash for me with dev. version 4.2.4.0.0+ (Build ID: fc70d91713332676dd2b8aa77d67684258493b15) under Ubuntu 13.10 x86-64

Best regards. JBF