Bug 72288 - EDITING: MATCH returns #N/A with "match_type" =0 in array formula with strings
Summary: EDITING: MATCH returns #N/A with "match_type" =0 in array formula with strings
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta1
Hardware: Other All
: medium critical
Assignee: Eike Rathke
URL:
Whiteboard: target:4.3.0 target:4.2.0.1
Keywords: regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-12-03 21:43 UTC by GerardF
Modified: 2013-12-03 23:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test case with match array function (12.03 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-12-03 21:43 UTC, GerardF
Details
Screenshot showing the MATCH() (73.94 KB, image/png)
2013-12-03 22:47 UTC, m.a.riosv
Details
Test case with the commented formulas (14.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-12-03 23:23 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description GerardF 2013-12-03 21:43:09 UTC
Created attachment 90190 [details]
test case with match array function

Sorry for version number but 4.3.0 alpha is not in the list... 
Ttested with Version: 4.3.0.0.alpha0+
Build ID: 56ad826194d0b9b42ed8bde35836b0e59c46baa6
TinderBox: Win-x86@39, Branch:master, Time: 2013-11-30_11:04:29
on Windows Vista.

Using MATCH in array context fails when "search_criterion" is string and "match_type" set to 0
=MATCH({"A";"B";"C"};{"A";"B";"C"};0) returns #N/A (3 times)
See test attachment.
Comment 1 GerardF 2013-12-03 21:49:32 UTC
Eike,

Could this be related to fix for https://bugs.freedesktop.org/show_bug.cgi?id=71589 ?
Comment 2 Eike Rathke 2013-12-03 22:27:39 UTC
No.
Comment 3 Eike Rathke 2013-12-03 22:41:24 UTC
Introduced somewhere along the SharedString implementation.
Comment 4 m.a.riosv 2013-12-03 22:47:29 UTC
Created attachment 90197 [details]
Screenshot showing the MATCH()

Works for me.
Win7x64Ultimate
Version: 4.3.0.0.alpha0+ Build ID: 86268546a09c3bdd0d5cb6bc047408db779e057c
TinderBox: Win-x86@47-TDF, Branch:master, Time: 2013-12-03_15:52:47
Comment 5 m.a.riosv 2013-12-03 23:23:01 UTC
Created attachment 90198 [details]
Test case with the commented formulas

I had not load the attached file, sorry.

Seems the issue is with the second parameter as range.

=MATCH({"A";"B";"C"};{"A";"B";"C"};0) works.
=MATCH(A16:A18;{"A";"B";"C"};0) works.
=MATCH({"A";"B";"C"};A16:A18;0) doesn't work.
=MATCH(A16:A18;A16:A18;0) doesn't work.
Comment 6 Commit Notification 2013-12-03 23:39:58 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=882665d821a2fc705b7ae03372c2ae7593028210

resolved fdo#72288 made case insensitive matrix string query work again



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-12-03 23:50:33 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=507afd9531a89e5c8ec07514a8f741ce21a0b78d&h=libreoffice-4-2

resolved fdo#72288 made case insensitive matrix string query work again


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.