Bug 72342 - Startcenter: document list not accessible
Summary: Startcenter: document list not accessible
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Start-Center-Accessibility
  Show dependency treegraph
 
Reported: 2013-12-05 10:14 UTC by Jacobo Aragunde Pérez
Modified: 2016-10-25 19:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacobo Aragunde Pérez 2013-12-05 10:14:58 UTC
The recent documents list in the new start center is not completely accessible. In particular, it doesn't produce the proper events when you navigate through the documents list using the arrow keys.

Steps to reproduce it:

* Enable screen reader.
* Open LibreOffice start center.
* Navigate with tab until you reach the recent documents list.
* Now use the arrows to highlight a different document. You will see that no voice notification of this change is emitted.

You can also open the accerciser tool and check the "focus" events in the "event monitor" tab. You will see that no events happen when you navigate through the documents, but they happen when you use tab to move to other places in the window.

It would also be good to add an event to notify that you have "tabbed" into the recent documents area.
Comment 1 V Stuart Foote 2013-12-05 18:12:33 UTC
Confirming as noted, also on Windows OS
Comment 2 Joanmarie Diggs 2013-12-12 09:46:40 UTC
1. focus: event is deprecated
2. object:state-changed:focused is not required if we get:
   a. object:state-changed:selected for the newly-selected item
   b. object:selection-changed from the parent, or
   c. object:active-descendant-changed from the parent if it manages descendants

We seem to be getting 2b.

Also just because Orca isn't presenting something (that you hear) does not necessarily mean it is a LibreOffice bug.

Given the fact that we seem to be getting the correct events, I'm closing this bug out. If I subsequently discover other issues related to this new UI, I will file them attaching specific accessible event listeners which demonstrate the issue without the use of Orca.