Bug 72361 - EDITING: Trendline: force intercept should be available for exponential trendline
Summary: EDITING: Trendline: force intercept should be available for exponential trend...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Laurent BP
QA Contact:
URL:
Whiteboard: BSA target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-05 14:29 UTC by Laurent BP
Modified: 2015-05-21 19:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2013-12-05 14:29:30 UTC
Problem description: 
LibreOffice 4.2 introduces new options for trend lines, among them "Force intercept". But this option is only available for linear and polynomial trend lines. It should also be available for exponential trend line:
f(x) = b.exp(m.x) with force intercept = b

Steps to reproduce:
1. create XY chart
2. insert exponential trend line

Current behavior:
Force intercept option is unavailable

Expected behavior:
Force intercept should be the value of b in equation 
f(x) = b.exp(m.x)

              
Operating System: All
Version: 4.2.0.0.alpha0+ Master
Comment 1 Jorendc 2013-12-06 17:09:35 UTC
Hi Laurent,

I did insert a XY (scatter) chart and while inserting a trend line on it, the option "force intercept" is available (selectable) for me.

Tested using Mac OSX 10.9 with LibreOffice 4.2 beta 2.

Kind regards,
Joren
Comment 2 Laurent BP 2013-12-06 17:43:42 UTC
(In reply to comment #1)
> Hi Laurent,
> 
> I did insert a XY (scatter) chart and while inserting a trend line on it,
> the option "force intercept" is available (selectable) for me.
> 
> Tested using Mac OSX 10.9 with LibreOffice 4.2 beta 2.
Thanks Joren for your test.
Option is available in beta 2, but has no effect.
I proposed to master a commit to make option available only for linear and polynomial trend lines, because option has no effect with other trend lines:
https://gerrit.libreoffice.org/#/c/6893/
It is on way to be reviewed.

This issue is to able to modify exponential trend line code, to be able to force intercept.
Comment 3 Jorendc 2013-12-06 18:03:31 UTC
(In reply to comment #2)
> Thanks Joren for your test.
> Option is available in beta 2, but has no effect.
Oh, I see :)
> I proposed to master a commit to make option available only for linear and
> polynomial trend lines, because option has no effect with other trend lines:
> https://gerrit.libreoffice.org/#/c/6893/
> It is on way to be reviewed.
That makes sense :-).

> This issue is to able to modify exponential trend line code, to be able to
> force intercept.

Lets mark it as NEW then. Thanks for your work and time making LibreOffice even better :)!

Joren
Comment 4 Commit Notification 2015-04-29 14:14:47 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fec037e68f0dea164915fbfe1db4699a3861adf4

tdf#72361 Forced intercept for exponentiial trendline

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Mike §chinagl 2015-05-21 16:08:39 UTC
This bug fix is mentioned in the release notes of the coming LibreOffice 5.0 (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0). Therefore it would be wonderful if this feature really worked well, otherwise it should not be mentioned in the release notes. In the notes it reads:

Force Intercept option is now also available for exponential trendlines. tdf#72361 (Laurent Balland-Poirier)
Comment 6 Laurent BP 2015-05-21 19:09:00 UTC
(In reply to Mike §chinagl from comment #5)
> This bug fix is mentioned in the release notes of the coming LibreOffice 5.0
> (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0).
> Therefore it would be wonderful if this feature really worked well,
> otherwise it should not be mentioned in the release notes. 

What do you mean with "if this feature really worked well"? Did you test it with LibO 5.0 test build? Did you detect some bug? If so, give a step by step procedure to reproduce the bug. Thanks.