Bug 72382 - wrong direction in Complex Text Layout
Summary: wrong direction in Complex Text Layout
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2013-12-06 05:52 UTC by Noori
Modified: 2015-01-13 14:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
result of RTL writing problem in picture (7.23 KB, application/x-gzip)
2013-12-06 05:52 UTC, Noori
Details
digits (from tarball) (3.54 KB, image/png)
2014-12-30 00:19 UTC, Robinson Tryon (qubit)
Details
parenthesis (from tarball) (4.10 KB, image/png)
2014-12-30 00:20 UTC, Robinson Tryon (qubit)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Noori 2013-12-06 05:52:30 UTC
Created attachment 90336 [details]
result of RTL writing problem in picture

1- When I write RTL in LibreOffice (pressing right ctrl+shift) and i change my keyboard layout to LTR language (for example EN) none alphabetic characters such as parenthesis and digits are in RTL language.
i.e.: I write “Function f(x) is.” in Farsi
See attached image parenthesis.png

2- I choose Tools -> Options -> Complex Text -> Digits -> Context, but when i change my keyboard layout to LTR language all digits shown in Farsi locale.
i.e. : I write “Weight 40 kilograms.” in Farsi
See attached image digit.png

LibreOffice is sensitive on direction only, but if it was sensitive on direction (RTL or LTR) and current keyboard layout (like MS Office) its better.

[~]$libreoffice --version
LibreOffice 4.1.3.2 410(Build:2)

I use LibreOffice in Farsi UI.

[~]$locale
LANG=fa_IR.utf8
LC_CTYPE="fa_IR.utf8"
LC_NUMERIC="fa_IR.utf8"
LC_TIME="fa_IR.utf8"
LC_COLLATE="fa_IR.utf8"
LC_MONETARY="fa_IR.utf8"
LC_MESSAGES="fa_IR.utf8"
LC_PAPER="fa_IR.utf8"
LC_NAME="fa_IR.utf8"
LC_ADDRESS="fa_IR.utf8"
LC_TELEPHONE="fa_IR.utf8"
LC_MEASUREMENT="fa_IR.utf8"
LC_IDENTIFICATION="fa_IR.utf8"
LC_ALL=
Comment 1 Benno Schulenberg 2013-12-14 13:05:01 UTC
Hello Noori, please don't attached tar files, they are too much of a hassle.  If you wish to post PNG files, please attach them directly and each one separately.
But better than picture files would be to copy-and-paste the text that you get in your file into this Bugzilla text field.  Or do you then get a different result?

It is not entirely clear to me what you type in, because the parenthesis.png file shows shows two lines containing "f(x", and the second one seems correct -- how did you obtain that one?  And the digits.png file shows three lines, and each seems to say "4 kilograms", not "40 kilograms" as you say in your report.

The "Complex script" in the bug title is not very accurate -- please consider changing it to "CTL" or "Complex Text Layout".

Anyway...  Isn't this bug a duplicate of bug #61795?
And maybe of bug #65508 too?

Bug #69109 also seems a duplicate and may contain a workaround that allows you to avoid the issue.  Also bug #49320 seems related, and probably several more.
Comment 2 Noori 2013-12-15 19:52:41 UTC
Yes its similar to bugs #61795, #69109 and #49320.
I explain images here

1-
Comment 3 Noori 2013-12-15 20:04:47 UTC
Yes its similar to bugs #61795, #69109 and #49320.
I explain images here

1- Problem with (), [] and {} in CTL, function f(x): should be f(x) تابع, but is (f(x تابع.

2- In MS-Office I want that digits be in context format, when my keyboard layout is Persian ۱ ۲ ۳ ۴ and 1 2 3 4 for English, but in LibreOffice its always in Persian format. I set in Tools->Options->Language Setting->Complex Text Layout->General Option->digits ---> Context.
Comment 4 Robinson Tryon (qubit) 2014-12-30 00:19:57 UTC
Created attachment 111496 [details]
digits (from tarball)
Comment 5 Robinson Tryon (qubit) 2014-12-30 00:20:20 UTC
Created attachment 111497 [details]
parenthesis (from tarball)
Comment 6 Yousuf Philips (jay) (retired) 2015-01-13 14:52:15 UTC
Works correctly for me in Arabic.

Version: 4.5.0.0.alpha0+
Build ID: 39ac529d141dcd4de534eddbcc6c07bc49367b90
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-01-04_00:40:43