Download it now!
Bug 72412 - Tables in Impress: when the background is changed, the font size changes
Summary: Tables in Impress: when the background is changed, the font size changes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2013-12-06 19:33 UTC by Jion
Modified: 2020-01-14 15:07 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation file exhibiting bug behavior (16.36 KB, application/vnd.oasis.opendocument.presentation)
2013-12-07 03:02 UTC, Robinson Tryon (qubit)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jion 2013-12-06 19:33:34 UTC
In a new impress document, insert a table and fill it with some random text.
Change the size of this text. Then, go to format-page and change the background to a bitmap or a color. Apply the changes. Look the size of text in the table changes.
Comment 1 Robinson Tryon (qubit) 2013-12-07 02:55:35 UTC
TESTING on LO 4.2.0.0.beta2 + UBuntu 12.04.3

(In reply to comment #0)
> In a new impress document, insert a table and fill it with some random text.

Insert -> Table -> (use default rows/columns)

> Change the size of this text. 

Marquis-select the entire table, then change the font size in the toolbar.

> Then, go to format-page and change the
> background to a bitmap or a color.

Format -> Page -> Background
Fill -> Color -> Orange

> Apply the changes.

- Click "OK"
- Get dialog "Background settings for all pages?" -> Click "OK"

> Look the size of text
> in the table changes.

Text changes back to original value.

NOTES:

- Each time the bg color is changed, the fontsize reverts.
- Textboxes are not affected in the same way
Comment 2 Robinson Tryon (qubit) 2013-12-07 02:55:52 UTC
Tag confirmation whiteboard.
Comment 3 Robinson Tryon (qubit) 2013-12-07 03:02:10 UTC
Created attachment 90387 [details]
Presentation file exhibiting bug behavior
Comment 4 Robinson Tryon (qubit) 2013-12-07 03:05:17 UTC
(In reply to comment #1)
>

Using new attachment "Presentation file exhibiting bug behavior", we can repro even faster.

REPRO STEPS:
- Open attachment (table-font-size-reverts-on-bg-change_fdo72412.odp)
- Observe fontsize in textbox and in table!
- Format -> Page -> Background
- Fill -> Color -> Orange
- Click "OK"
- Get dialog "Background settings for all pages?" -> Click "OK"

Result: font size in table will have shrunk down to default value
Comment 5 Robinson Tryon (qubit) 2013-12-07 03:09:36 UTC
(In reply to comment #4)
> REPRO STEPS:
> - Open attachment (table-font-size-reverts-on-bg-change_fdo72412.odp)
> - Observe fontsize in textbox and in table!
> - Format -> Page -> Background
> - Fill -> Color -> Orange
> - Click "OK"
> - Get dialog "Background settings for all pages?" -> Click "OK"
> 
> Result: font size in table will have shrunk down to default value

NoRepro in LO 4.1.2.2 (Ubuntu 12.04.3).

Keyword: regression 
Priority/Severity: Bumping up to high/major.

Nice catch, Jion!
Comment 6 Andras Timar 2014-03-24 18:25:48 UTC
I could not reproduce the bug at all with the attached document. However, following instruction in comment 1, the bug was reproduced even in LibreOffice 4.1.2.2. In LibreOffice 4.0.3.3 the bug was not reproduced. It is not a 4.2 regression, but earlier.
Comment 7 Andras Timar 2014-03-25 14:38:41 UTC
a00b62422e5499e842d0b3b6302ba79f3d808c27 is the first bad commit
commit a00b62422e5499e842d0b3b6302ba79f3d808c27
Author: Gokul <gswaminathan@kacst.edu.sa>
Date:   Sat Feb 2 15:29:56 2013 +0300

    Fixes fdo#46186, The Table Remains in the defined writing mode.
    
    The table in impress is drawn under the rectangular are, on Selecting
    the table it was only selecting the rectangular area and not the cells
    inside, Making the layout to be as RTL which was mirroring the table.
    
    But, We need the table to be in RTL Writing mode and not mirroring the
    table. Now on applying my patch, If table is selected, it will select
    the entire cells inside which is the actual table and the functionality
    works fine.
    
    Change-Id: I9d6bdde5019322488be66fa89a6488d348b2cf44
    Reviewed-on: https://gerrit.libreoffice.org/1964
    Reviewed-by: Ahmad Harthi <aalharthi@kacst.edu.sa>
    Tested-by: Ahmad Harthi <aalharthi@kacst.edu.sa>
Comment 8 Robinson Tryon (qubit) 2015-12-13 11:09:30 UTC Comment hidden (spam)
Comment 9 Justin L 2017-02-25 12:01:05 UTC
Using the procedure in comment 1, I was able to reproduce in LO 3.5 (bibisect-43all).  I also used 5.4alpha with a revert of the commit from comment 7, and that did not "fix" the problem.  Removing regression/bibisected tags.
Comment 10 Sung-Po Chen 2018-11-29 09:33:50 UTC
still exists.
But the Front size in properties won't change after change the background color, and the front size of the words we actually see will change to the original size.

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded
Comment 11 QA Administrators 2019-11-30 03:39:27 UTC Comment hidden (obsolete)
Comment 12 Roman Kuznetsov 2019-12-28 12:56:53 UTC
don't repro in

Version: 6.5.0.0.alpha0+
Build ID: e22a3f596ce50b5166063e217d96ef674a54d380
CPU threads: 4; OS: Mac OS X 10.15.2; UI render: GL; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

I tried steps from Comment 1

but now I don't see the "- Get dialog "Background settings for all pages?" -> Click "OK""

people , please retest it yourself too
Comment 13 Buovjaga 2020-01-14 15:07:15 UTC
Yep, no problem now.

Arch Linux 64-bit
Version: 6.5.0.0.alpha0+
Build ID: 94c1f5cfb96a826220b64608cf0ada76d3bdde31
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 14 January 2020