Bug 72466 - CONFIGURATION: Wrong colours for 'Automatic' settings
Summary: CONFIGURATION: Wrong colours for 'Automatic' settings
Status: RESOLVED DUPLICATE of bug 61246
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-08 08:51 UTC by megamitzu
Modified: 2015-01-27 16:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Scrrenshot with 'Appearance' dialogs of 3.6.2.2 amd 4.1.3 side by side showing different 'Autoatic' colour settings. (284.37 KB, image/png)
2013-12-08 08:51 UTC, megamitzu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description megamitzu 2013-12-08 08:51:29 UTC
Created attachment 90448 [details]
Scrrenshot with 'Appearance' dialogs of 3.6.2.2 amd 4.1.3 side by side showing different 'Autoatic' colour settings.

Problem description: 
The colours used when the 'Automatic' setting is selected for custom UI components' cplours are not based on the current system (window manager) scheme.
Steps to reproduce:
1. Tools/Options/Libre Office/Appearance
2. When 'Automatic' (default) is selected for UI components in 'Custom colors',  the colours for Document background and Font Color are white and black respectively. They do not match the current system scheme.

Current behavior: 'Automatic' colours for document background and font are white and black, respectively.

Expected behavior: They should match the window and text colours from the system wide colour scheme in use, which may be different from white and black.

This is particularly visible when a dark colour scheme like 'XFCE dawn' is used for the window manager - see attachment (3.6.2.2 displays the right colours).

Versions in-between 3.6.2.2 and 4.1.3 were not tested!

System: Xubuntu 12.10 with xfce 4.10.
This is particularly visible with 

              
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 Buovjaga 2014-10-25 14:20:21 UTC
Might not be related, but please see, if you have this setting enabled by accident: https://help.libreoffice.org/Common/Accessibility#Automatically_detect_high_contrast_mode_of_operating_system

Also, does this happen with the latest stable?
Comment 2 Buovjaga 2015-01-13 09:40:34 UTC
Ok, I confirmed the problem by testing it myself, installing https://github.com/vkuzel/Xfce-darkness on Scientific Linux 7 64-bit, Xfce 4.10.

If anyone else wants to test: copy the gtk-2.0 folder to ~/.themes/xfce-darkness/ and select the theme from the Xfce settings.

The problem is not related to the automatic high contrast setting in LibO.

However, the problem is already present in 3.6.2.2 for me, but maybe there is something I don't understand. 4.5 alpha shows black panel UI colors otherwise like in the screenshot, but 3.6.2.2 does not.

Thus, I don't dare to add a bibisectRequest.

I think this is not isolated to Xfce, so testing with dark themes on other DEs is appreciated.

Version: 4.5.0.0.alpha0+
Build ID: 9763b55eb946cf425220d26dab91bf220890b180
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-08_12:56:53

Version 3.6.2.2 (Build ID: da8c1e6)
Comment 3 Michael Stahl (CIB) 2015-01-27 16:27:45 UTC

*** This bug has been marked as a duplicate of bug 61246 ***