Bug 61246 - CONFIGURATION: document background is white, even if desktop theme uses other color
Summary: CONFIGURATION: document background is white, even if desktop theme uses other...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 72466 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-21 19:05 UTC by Viktor
Modified: 2015-01-27 16:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Viktor 2013-02-21 19:05:39 UTC
Problem description: 
I'm using custom window color in windows, namely RGB: 252, 247, 209.  I have installed LibreOffice 4.0.0.3 first time and after opening Writer or Calc, document background is still white. I have checked settings Tools -> Options -> LibreOffice -> Appearance and Document Background is set to Automatic.


Steps to reproduce:
1. Mouse right click on desktop, Personalize, Window Color, Advanced appearence settings ..., choose Windows and setup different color.
2. Install LibreOffice 4.0.0.3.
3. Open Writer.

Current behavior:
white color is shown

Expected behavior:
color setup for windows should be shown
              
Operating System: Windows 7
Version: 4.0.0.3 release
Last worked in: 3.6.5.2 release
Comment 1 Urmas 2013-02-22 14:09:20 UTC
'Automatic' document background color should be of COLOR_WINDOW, not white.
Comment 2 Michael Stahl (CIB) 2013-02-25 20:41:28 UTC
this was changed intentionally, and the change will be in 3.6.6 too:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f10bb02eb3083a089e3ca28c45983e616ef84d58&h=libreoffice-3-6

this means it's not a bug, it's a feature.

given that the paper you print your WYSIWYG Writer document on
doesn't follow the Windows color theme either, i agree with the change.
Comment 3 Stephan Hennig 2013-03-14 22:11:11 UTC
@Michael: There are two (I can think of) ways to determine visible background colour, depending on the meaning of the colour.

1. Background reflects a document property.

2. Background reflects a UI property.

I couldn't find means in LibreOffice to set the paper colour of a document.  That's not a surprise, because you hardly ever use ink to colour a page.  Instead, documents are printed to coloured paper.  Such paper colour is outside of LibreOffice's control.  (BTW, menu Format => Page => Background doesn't set a printed page background, but the background of the type area only.)

Having said that, it seems more sensible to consider visible background a UI property.  Best default for that is to follow system theme.

Now, LibreOffice 4.0 throws in a third colour, white, without any relation to one of both alternatives discussed above.  This seems a rather random change.  
The commit message mentioned in comment 2 reads:

> The font and document color of a Writer document or an
> Impress presentation should not be derived from a desktop
> theme. A Writer documents needs to look good on paper. An
> Impress presentation may have it's own theme. The
> appearance of a document should not change by changing the
> desktop theme.
> 
> With this change a document looks the same on any computer
> if the user do not change the default colors.

Concerning Writer documents looking good on paper, how does that justify a hard-coded white background?  When looking on white paper, you see reflected light.  A computer screen, on the other hand, emits light.  Staring at a screen is much more a strain to the eye than to look at paper.  That's the reason some people change system-wide background to a less aggressive colour.  And as is written above, LibreOffice actually has no way to know the colour of the paper a document is printed to.

Concerning Impress documents, that is a valid concern, but a special case.  But keep in mind that a silver screen, again, /reflects/ light.  Therefore, a white presentation background is not too much a strain to the eye.

How about a new per-document setting, that allows to determine the meaning of the background colour?  For Impress documents, that could certainly default to some particular colour (white).  For Writer and Calc documents, the previous default (following system theme) seems more sensible.

Side note, neither has this change to LibreOffice 4.0 been mentioned in the release notes, nor did I see a description how to change it back to LibreOffice 3.6.5 behaviour.

Thanks,
Stephan Hennig
Comment 4 Viktor 2013-05-04 19:35:17 UTC
Dear Michael,

is it possible to follow this to make it configurable, whether white or Window_color will be used?
Comment 5 Michael Stahl (CIB) 2015-01-27 16:27:45 UTC
*** Bug 72466 has been marked as a duplicate of this bug. ***
Comment 6 Michael Stahl (CIB) 2015-01-27 16:35:37 UTC
just for the record, bug 71511 presented a valid accessibility use-case
for using desktop theme colors.