Bug 72469 - VIEWING: Document Preview in LibreOffice StartCenter not working for PDFs
Summary: VIEWING: Document Preview in LibreOffice StartCenter not working for PDFs
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: BSA target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-08 10:39 UTC by saahleinad
Modified: 2014-08-01 17:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of non-existent preview of a previously opened PDF document (64.57 KB, image/png)
2013-12-08 10:39 UTC, saahleinad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description saahleinad 2013-12-08 10:39:51 UTC
Created attachment 90450 [details]
Screenshot of non-existent preview of a previously opened PDF document

Problem description: 

Steps to reproduce:
1. Open a simple PDF document (without embedded OpenDocument Text)
2. Close LibreOffice
3. Open the new LibreOffice Main Window

Current behavior:

No thumbnail/preview of previously opened PDF in the "recent documents" area.

Expected behavior:

A simple thumbnail/preview of previously opened PDF in the "recent documents" area.
Operating System: Ubuntu
Version: 4.2.0.0.beta2
Comment 1 Jean-Baptiste Faure 2013-12-08 13:43:57 UTC
It seems that previews are available in the StartCenter only for ODF files.
For ODF files it is easy to get the preview because it is in the zip container. So you can extract the preview without really open the file.
It seems that it is not the case for ooxml and pdf files.

Hi Kendy, do you confirm ? 

Best regards. JBF
Comment 2 retired 2013-12-09 11:07:52 UTC
Can confirm this. And agree it would be nice to show the first page of a PDF file in the startcenter. Setting to NEW.
Comment 3 V Stuart Foote 2014-01-04 21:25:25 UTC
Setting as enhancement, PDF are filter input into Draw (with pretty good fidelity). It can be saved at that point and you'd have first slide/page of the .ODG held in the ODF container.

But if the PDF is just closed--there is no ODF rendering for use as a thumbnail. Instead it is represented with the generic LibreOffice ODF Icon.

This enhancement would require refactoring of the ThumbNailView as well as identifying some location in the user profile to hold the first page views. 

Enhancement could be a value since a similar treatment might be possible for other non-ODF formats, e.g. TXT, DOC, DOCX, PPT, PPTX, XLS, XLSX, etc.
Comment 4 Commit Notification 2014-02-04 08:13:08 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e2eda70f2746f08376d8cdf5e5360df217335aef

startcenter: fdo#72469: Thumbnails also for other file types than ODF.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Jan Holesovsky 2014-02-04 08:15:04 UTC
All the file types are thumbnailed now :-)
Comment 6 retired 2014-02-04 10:21:34 UTC
Thanks Jan, this is a great improvement for the StartCenter :)
Comment 7 saahleinad 2014-02-04 10:52:18 UTC
I love you guys for being inclusive, eventhough ODF is the best <3 and I love LibreOffice, thanks Jan
Comment 8 retired 2014-02-07 19:45:47 UTC
and verified.