Bug 72477 - Search / Find misses warning on Top of the Document on a particular (type of) Document
Summary: Search / Find misses warning on Top of the Document on a particular (type of)...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2013-12-08 13:26 UTC by Gabriele Ponzo
Modified: 2017-12-30 11:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Ponzo 2013-12-08 13:26:31 UTC
Just on WG40-WriterGuideLO it happens that seeking for a text towards bottom of the documents gives the right warning to ask if to continue searching from the Top, but it misses if you try backwards: it just goes to the next recurrence on the bottom of document, without warning.

IT HAPPENS JUST ON WG40-WriterGuideLO Document, but also in 4.1.3.2 release.
Comment 1 pierre-yves samyn 2013-12-08 16:55:30 UTC
Hello

I do not reproduce on windows 7/64 & Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d

Please, Could you be more specific and give more details ?
What is the searched text ? Do you use Edit> Find or Edit> Find & Replace ?

For example:

Steps to reproduce:

1. Start LibreOffice
2. File> Open> WG40-WriterGuideLO
3. Edit> Find
4. Type foo in the Find text zone
5. Click "Find next" x times
6. ...

Note: I first launch the software (step 1) to be sure not to keep options may disturb the search.

Regards
Pierre-Yves
Comment 2 Jean-Baptiste Faure 2013-12-08 17:01:16 UTC
I do not reproduce with version 4.2.0.0.beta2+ under Ubuntu 13.10 x86-64.

What I did:
1/ download https://wiki.documentfoundation.org/images/9/96/WG40-WriterGuideLO.odt
2/ open this document with LibreOffice
3/ go to some page inside the document
4/ ctrl+F to open the search bar and type a string which is not in the document, like "azertyuiop"
5/ click on then down arrow ==> you get the message asking to continue searching at the beginning
6/ click on the up arrow ==> you get the message asking to continue searching at the end

Best regards. JBF
Comment 3 Cor Nouws 2013-12-08 22:17:49 UTC
@pierre-yves: Gabriele mentioned the issue on IRC and I was not able to reproduce on Ubuntu indeed. But without that specific document...
@Gabriele fr my convinience: do you pls have link to the document?
thanks?

Or maybe Mac-only?
Comment 4 Jorendc 2013-12-08 22:19:31 UTC
Can't reproduce, tested using Mac OSX 10.9 with LibreOffice Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d
Comment 5 Gabriele Ponzo 2013-12-09 10:30:24 UTC
This is the link to the file: https://wiki.documentfoundation.org/images/9/96/WG40-WriterGuideLO.odt

I'd like to attach a screencam if it would be possible, since there happens a so many unpredictable behaviors oh this (valuable) document that it would be too long to describe them all…

For example:

1.  Start LibreOffice
2.  File> Open> WG40-WriterGuideLO
3.  Edit> Find
4.  Type "protect" and then the Down Arrow
5.  It reaches the first recurrence of protect word in Page 0 - TOC (3rd page)
6.  Push Up Arrow in Find Bar
7.  It gives the warning to proceed searching from the bottom
8.  Press YES
9.  It look like it found another recurrence at the bottom, but without moving the view to the point of finding
10. Push Up Arrow again in Find Bar
11. Cycle from point 9. about 6 times until seeing the view moving
12. Press Down Arrow in Find Bar
13. It look like it found another recurrence at the bottom, but without moving the view to the point of finding
14. Cycle from point 9. about 6 times until having the warning  to continue searching from the top

It looks like there are problems managing last pages (Index), or I though also some problem may arise jumping in and out of tables, which determines the appearing and disappearing of the Table Toolbar with a delay for that…

I've noticed same behaviors using Edit> Find & Replace (with Backwards advanced option checked when needed)

I have an iMac 27" late 2009 with a (self made) Fusion Drive (128GB SSD + 3TB HDD) and I had already installed all this before installing this Beta:
+ LibreOffice Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a
with Italian Package
+ Sun OpenOffice.org 3.2.0 - OOO320m12 (Build:9483) - almost never used
+ NeoOffice 3.1.2 Patch 9 - never used

Finally I can state that I get the same problem with LibO 4.1.3.2.

Hope to have been useful and available for further infos.
Comment 6 Owen Genat (retired) 2014-07-22 11:45:30 UTC
(In reply to comment #5)
> 6.  Push Up Arrow in Find Bar
> 7.  It gives the warning to proceed searching from the bottom

Under MacOS 10.6.8 using v4.3.0.3 Build ID: fcd3838c4097f7817b5b3984fd88a44e1edd8548 (x86) I never get the indicated dialog. It is at this point that the search process goes into limbo. Subsequent clicking on the up and down arrows in the search toolbar produce highly erratic behaviour i.e., up searches down, down searches up, etc. 

Under GNU/Linux x86_64 using v4.2.5.2 the detailed description in comment 5 is a fairly accurate representation of what occurs i.e., the search appears to the continue (as evidenced by the changing tab positions in the ruler) but the viewing position in the document is never updated. Under GNU/Linux x86_64 using v4.4.0.0alpha+ (2014-07-19) the behaviour is more in keeping with the MacOS experience.

There is evidently some kind of problem here and it appears to affect all platforms / builds to some degree. Status set to NEW. Platform set to All/All.
Comment 7 QA Administrators 2015-09-04 02:48:37 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-11-19 12:19:36 UTC
No problem anymore: please retest!

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 66d2b72667792cb18b25805387824d636e2a455c
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-18_02:35:53
Locale: fi-FI (fi_FI)
Comment 9 QA Administrators 2017-10-23 14:02:02 UTC Comment hidden (obsolete)
Comment 10 Cor Nouws 2017-12-30 11:49:42 UTC
(In reply to Buovjaga from comment #8)
> No problem anymore: please retest!
> 
> Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
> Build ID: 66d2b72667792cb18b25805387824d636e2a455c
> TinderBox: Win-x86@39, Branch:master, Time: 2015-11-18_02:35:53
> Locale: fi-FI (fi_FI)

> worksForMe