Bug Hunting Session
Bug 72500 - FORMATTING: Letters are more up on Mac than on Windows version of LO at the same line spacing
Summary: FORMATTING: Letters are more up on Mac than on Windows version of LO at the s...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: NoRepro:4.2.0.1:OSX NoRepro:4.3.0.0a0...
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2013-12-09 02:19 UTC by deepjungle.maca
Modified: 2014-02-07 22:03 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Source (9.32 KB, application/vnd.oasis.opendocument.text)
2013-12-09 02:19 UTC, deepjungle.maca
Details
Windows (15.32 KB, application/pdf)
2013-12-09 02:22 UTC, deepjungle.maca
Details
Mac (15.31 KB, application/pdf)
2013-12-09 02:22 UTC, deepjungle.maca
Details
worksforme screenshot LO4.2.0.3, OSX 10.9.1 (126.44 KB, image/png)
2014-01-24 15:01 UTC, retired
Details
worksforme screenshot LO4.2.0.3, OSX 10.9.1 palantino (39.92 KB, image/png)
2014-01-27 23:54 UTC, retired
Details
Information about used Palatino Linotype font (56.94 KB, image/png)
2014-01-28 12:08 UTC, deepjungle.maca
Details
Video record of the problem (2.36 MB, video/quicktime)
2014-01-28 12:45 UTC, deepjungle.maca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deepjungle.maca 2013-12-09 02:19:25 UTC
Created attachment 90484 [details]
Source

Letters are more up on Mac than on Windows version of LO at the same line spacing

Check the both attached PDF output from Mac and Windows version. This made hard interoperability between platforms. 

Tested LO 4.1.3 and LO 4.2.0 beta2 on Windows 7 and Mac OS X 10.9

The used font is Palatino Linotype.
Comment 1 deepjungle.maca 2013-12-09 02:22:00 UTC
Created attachment 90485 [details]
Windows
Comment 2 deepjungle.maca 2013-12-09 02:22:21 UTC
Created attachment 90486 [details]
Mac
Comment 3 retired 2013-12-31 11:37:10 UTC
NoRepro:4.2.0.1:OSX NoRepro:4.3.0.0a0+:OSX

WORKSFORME.

deepjungle: Can you please try and see if this problem still exists for you with  the latest pre-release 4.2.0.1: http://www.libreoffice.org/download/pre-releases/

In that case, please re-open. I see: http://cl.ly/image/0S0I2B2B2R1T which looks identical to your windows screenshot.
Comment 4 deepjungle.maca 2014-01-01 07:34:42 UTC
Unfortunately, no change on Mac OS X 10.9
Comment 5 retired 2014-01-01 11:17:14 UTC
deepjungle that is intersting. I tested with 10.9.1 here so…

Which LO version have you tested?
Comment 6 deepjungle.maca 2014-01-01 13:43:07 UTC
Please, check this screenshot: https://dl.dropboxusercontent.com/u/9411508/Screen%20Shot%202014-01-01%20at%2014.37.42.png

I've tried the latest build of 4.2.0.1+

BTW: Used font is Palatino Linotype, not Palatino

Palatino Linotype is a built-in font in Windows and can be installed with some MS products on Mac
Palatino is a built-in font in OS X
Comment 7 deepjungle.maca 2014-01-24 13:26:53 UTC
Hi,
this is still not solved. Can this issue be re-opened?
Comment 8 retired 2014-01-24 15:01:06 UTC
Created attachment 92732 [details]
worksforme screenshot LO4.2.0.3, OSX 10.9.1
Comment 9 retired 2014-01-24 15:03:21 UTC
Hm, I'm confused. We're both on 10.9.1. Did you try LO 4.2.0.3? http://www.libreoffice.org/download/pre-releases/

Looks good for me (see screenshot)
Comment 10 deepjungle.maca 2014-01-24 16:28:58 UTC
But you use Times New Roman but the document uses Palatino Linotype font. Take a look at my Comment 6.
Comment 11 deepjungle.maca 2014-01-27 18:32:23 UTC
Is my explanation clear or not? The bug is still there.

Please, notice you use New Times Roman font, but I use Palatino Linotype font.
Comment 12 retired 2014-01-27 23:53:05 UTC
deepjungle: that's not true. I am using your test file. times new roman is only displayed because I was outside the table.

new screenshot with cursor in the table and font palantino linotype, same result.
Comment 13 retired 2014-01-27 23:54:04 UTC
Created attachment 92895 [details]
worksforme screenshot LO4.2.0.3, OSX 10.9.1 palantino
Comment 14 deepjungle.maca 2014-01-28 12:06:43 UTC
Unfortunately, I've tried it on newly fresh install MacBook Pro 15" 2013
late. So I can reproduce it on two different machines with completely setup.

Please, take a look at a version of your Palatino Linotype's fonts. Check
the new screenshot.


2014-01-28 <bugzilla-daemon@freedesktop.org>

>   *Comment # 13 <https://bugs.freedesktop.org/show_bug.cgi?id=72500#c13>
> on bug 72500 <https://bugs.freedesktop.org/show_bug.cgi?id=72500> from Foss
> <foss@openmailbox.org> *
>
> Created attachment 92895 [details] <https://bugs.freedesktop.org/attachment.cgi?id=92895> [details] <https://bugs.freedesktop.org/attachment.cgi?id=92895&action=edit>
> worksforme screenshot LO4.2.0.3, OSX 10.9.1 palantino
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 15 deepjungle.maca 2014-01-28 12:08:28 UTC
Created attachment 92920 [details]
Information about used Palatino Linotype font
Comment 16 deepjungle.maca 2014-01-28 12:45:24 UTC
Created attachment 92921 [details]
Video record of the problem
Comment 17 deepjungle.maca 2014-01-28 12:46:08 UTC
I added a video record of the problem directly from LO.
Comment 18 deepjungle.maca 2014-02-07 16:44:44 UTC
Can be this bug re-opened again? I uploaded the video shown the problem clearly I guess :)
Comment 19 retired 2014-02-07 20:43:48 UTC
So with which OSX LO is this video made with?
Comment 20 deepjungle.maca 2014-02-07 22:03:06 UTC
The setup is following:

- Mac OS X 10.9.1 -- MacBook Air 13", Mid 2013, Intel Core i7 1,7 GHz
- LO 4.2.0.4