Download it now!
Bug 72677 - Hebrew letter position skewed in lines containing spaces
Summary: Hebrew letter position skewed in lines containing spaces
Status: RESOLVED DUPLICATE of bug 48402
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-13 12:40 UTC by Shahar Evron
Modified: 2014-10-07 10:34 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
See red line marking the page boundary and red squares marking shifted characters (139.35 KB, image/png)
2013-12-13 12:40 UTC, Shahar Evron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shahar Evron 2013-12-13 12:40:20 UTC
Created attachment 90718 [details]
See red line marking the page boundary and red squares marking shifted characters

In recent versions (not sure but I believe after 4.0), writing Hebrew (RTL) on Mac shows a new bug which makes things almost unusable:

When writing any text that has spaces in it, letters will shift right while writing by about half-a-letter once a space is added, which makes the text unreadable. After a second or so of idle time, or after moving to a new line, the letters "adjust" and will no longer be half-hidden be eachother but instead the whole line will be shifted to the right beyond the page boundary. 

I've tried this with several different fonts and did not seem to show any difference. 

Lines with no spaces in them seem to be fine, although that doesn't really cover any real text. 

To reproduce:
1. Create a new Writer document on Mac 
2. Write some Hebrew text with spaces

Screenshot demonstrating the problem is attached.
Comment 1 Shahar Evron 2013-12-13 13:10:37 UTC
I've confirmed the same bug on version 4.2.0.0.beta2
Comment 2 Alex Thurgood 2014-10-07 10:34:36 UTC
Apparently fixed in master 440 alpha, but not backported because changes deemed too invasive

*** This bug has been marked as a duplicate of bug 48402 ***