Download it now!
Bug 72691 - IF function inside an array formula fails to track cell value change.
Summary: IF function inside an array formula fails to track cell value change.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.3.0 target:4.2.2 target:4.1.6
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-12-13 20:50 UTC by KarlM
Modified: 2015-12-15 22:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
spreadsheet to innustrate the bug (9.00 KB, application/msword)
2013-12-13 20:50 UTC, KarlM
Details
A very tiny minimalistic document to demo this. (10.83 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-14 18:26 UTC, Kohei Yoshida
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KarlM 2013-12-13 20:50:00 UTC
Created attachment 90745 [details]
spreadsheet to innustrate the bug

Calc formatting error. See attached file.

Delete the date in cell B5 and cell F5 goes blank as expected. Type the date back in B5 and F5 stays blank; it should fill in again. Close and reopen the file in Calc and the date in F5 is filled in.

I have confirmed this on Win7-64 with LibreOffice 4.1.3, 4.1.4 RC2 and 4.2.0 Beta 2.

Thanks,

...Karl
Comment 1 m.a.riosv 2013-12-14 00:03:29 UTC
Hi KarlM, thanks for reporting.

Confirmed:
Win7x64Ultimate
Version: 4.1.5.0.0+ Build ID: d1bb23e95e3c4ffd325d739b52bfe2910368a03
Version: 4.2.0.0.beta2+ Build ID: 61a91e69eb627a86a7358e3d65a0892ac8dc4d9d
         TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2013-12-11_00:41:52

Only one/several hard recalc [Ctrl+Shift+F9], doesn't work.

Retaining pushed [Ctrl+Shift+F9] do the calculation.

Works with:
Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)
Comment 2 Joel Madero 2014-02-13 06:00:50 UTC
This one is a duplicate of another bug - not sure the bug # but if one of you find it please close this one :) Thanks!

P.S. The other one has activity by Kohei working on it and I believe it's currently on REOPENED status because it was believed to be fixed but has been confirmed to be broken still
Comment 3 m.a.riosv 2014-02-13 22:38:07 UTC
Still reproducible.
Win7x64
Version: 4.2.1.0.0+ Build ID: 58df669ac734f4740cf1112867edb808789aae43
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-12_13:26:56
Comment 4 Kohei Yoshida 2014-02-14 18:26:39 UTC
Created attachment 94092 [details]
A very tiny minimalistic document to demo this.

Even this single cell matrix example is enough to reproduce this case.
Comment 5 Kohei Yoshida 2014-02-15 01:33:22 UTC
I got this.
Comment 6 Commit Notification 2014-02-15 01:48:07 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ffec457c86df0906b358ac431ffdb5d1d47de8c

fdo#72691: Write unit test for this.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-02-15 01:48:21 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9bf907a8278cecd816368db7b8c4ab745a914a59

fdo#72691: Allow overwriting of string value with numeric one.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Kohei Yoshida 2014-02-15 01:55:33 UTC
Backport requests:

4.2: https://gerrit.libreoffice.org/8064
4.2.1: https://gerrit.libreoffice.org/8065
4.1: https://gerrit.libreoffice.org/8066
Comment 9 Commit Notification 2014-02-15 04:56:49 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b34c818bae7131c94f4a29257413c71536b8374d&h=libreoffice-4-2

fdo#72691: Allow overwriting of string value with numeric one.


It will be available in LibreOffice 4.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-02-18 00:22:03 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=30363f94b94b183f4e9b0f6d9699e76f398154dc&h=libreoffice-4-2-1

fdo#72691: Allow overwriting of string value with numeric one.


It will be available already in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Kohei Yoshida 2014-02-18 00:26:15 UTC
Fixed.
Comment 12 m.a.riosv 2014-02-20 22:23:48 UTC
Hi Kohei, thanks.
Verified in:
Win7x64Ult.
Version: 4.2.3.0.0+ Build ID: 7af1124f83df4d96f6ebe58536de7c51406df661
   TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-20_11:39:39
Version: 4.3.0.0.alpha0+ Build ID: 637353bb46d3c7d9537e47e4e003aef78a0c0ab3
   TinderBox: Win-x86@39, Branch:master, Time: 2014-02-19_01:39:31
I can't find 4.2.2 and I think 4.2.1 was released before the patch.
Comment 13 Michael Stahl (CIB) 2014-02-21 11:15:05 UTC
correcting target, since 4.2.1.1 is 4.2.1 release
Comment 14 Commit Notification 2014-03-06 20:45:49 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ebdf24c6731ccffb6dbd6e3487cd919890c844b3&h=libreoffice-4-1

fdo#72691: Allow overwriting of string value with numeric one.


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 m.a.riosv 2014-03-18 21:52:01 UTC
Verified in:
Win7x64
Version: 4.1.6.0.0+ Build ID: 0b772a163b2536fc55aa3b4de925119e33af769
Comment 16 Robinson Tryon (qubit) 2015-12-15 22:22:04 UTC
Migrating Whiteboard tags to Keywords: ()
Remove redundant 'ConfirmedRegression'
[NinjaEdit]