Bug Hunting Session
Bug 72739 - MATCH function returns wrong result
Summary: MATCH function returns wrong result
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-16 02:50 UTC by lysu98
Modified: 2015-01-19 12:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example data, formula used, and wrong results marked (146.83 KB, image/png)
2013-12-16 02:55 UTC, lysu98
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lysu98 2013-12-16 02:50:16 UTC

    
Comment 1 lysu98 2013-12-16 02:55:19 UTC
Created attachment 90815 [details]
Example data, formula used, and wrong results marked
Comment 2 m.a.riosv 2013-12-17 02:32:54 UTC
Hi lysu98, thanks for reporting.

MATCH() function accepts regular expressions for search and + is one of them, so there are two options:
- Disable regular expressions in Menu/Tools/Options/LibreOffice calc/Calculate - Enable regular expressions in formulas.
- Replace/substitute + with \+ in the search criterion.
  e.g. SUBSTITUTE(D12;"+";"\+") instead D12

Changed status to NOTABUG, please if you are not agree reopen it.
Comment 3 lysu98 2013-12-17 14:15:57 UTC
Thanks!

-- Lingyun


> On Dec 16, 2013, at 9:32 PM, bugzilla-daemon@freedesktop.org wrote:
> 
> mariosv changed bug 72739 
> What	Removed	Added
> Status	UNCONFIRMED	RESOLVED
> Resolution	---	NOTABUG
> CC	  	mariosv@miguelangel.mobi
> Comment # 2 on bug 72739 from mariosv
> Hi lysu98, thanks for reporting.
> 
> MATCH() function accepts regular expressions for search and + is one of them,
> so there are two options:
> - Disable regular expressions in Menu/Tools/Options/LibreOffice calc/Calculate
> - Enable regular expressions in formulas.
> - Replace/substitute + with \+ in the search criterion.
>   e.g. SUBSTITUTE(D12;"+";"\+") instead D12
> 
> Changed status to NOTABUG, please if you are not agree reopen it.
> You are receiving this mail because:
> You reported the bug.