Download it now!
Bug 72769 - MAILMERGE: Be able to mail merge to a new writer document directly without intermediary file
Summary: MAILMERGE: Be able to mail merge to a new writer document directly without in...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-16 23:35 UTC by pete
Modified: 2016-03-21 08:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot describing what I'm talking about (60.31 KB, image/png)
2013-12-16 23:35 UTC, pete
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pete 2013-12-16 23:35:27 UTC
Created attachment 90847 [details]
Screenshot describing what I'm talking about

When you print a Writer document with database fields, it asks:

"Your document contains address database fields. Do you want to print a form letter?"

When you click "Yes", a "Mail Merge" dialog box appears and asks if you want to output it to the "Printer" or to a new "File" on the disk.

I want neither. I want to display the output to a new Writer window without having to create a dummy intermediary file on disk.
Comment 1 pierre-yves samyn 2014-06-21 12:17:06 UTC
Hi

I confirm what you say: with File> Print it is not possible to generate the result of the merge without saving the document (or print).

However it is possible with Tools> Mail merge wizard> 7. Personnalize>
Edit individual.

Moreover, if you only want to view the result, it is perhaps not necessary to generate all the merge: Select a record in the data Sources Windows then click on the Data to fields button.

Does that answer your question?

Regards
Pierre-Yves
Comment 2 Alex Thurgood 2015-01-03 17:39:28 UTC
Adding self to CC if not already on
Comment 3 QA Administrators 2015-07-18 17:36:01 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 4 pete 2015-08-13 04:45:03 UTC
"Tools > Mail merge wizard > 7. Personnalize > Edit individual" creates a read only view, not a new editable document.
Comment 5 Alex Thurgood 2015-08-13 09:47:46 UTC
@pete : which version of LibreOffice are you using ? You didn't specify one in the version field of the bug report.

Also, there is new functionality either being developed or already in LibreOffice 5.0.0.5 (I haven't checked) which is supposed to avoid the creation of an intermediate ODB file, by embedding the data source (only text, e.g. CSV, etc, or Calc, from what I understand) directly into the Writer document.

Try testing with a 5.0.0.5 version or a daily/nightly build and report back here.
Comment 6 Cor Nouws 2016-03-21 08:25:31 UTC
Hi Pete,

I guess when you test 5.1 that this issue is resolved?
  https://wiki.documentfoundation.org/ReleaseNotes/5.1
  http://vmiklos.hu/blog/mail-merge-embedding.html

I set this issue to WorksForMe - fixed we only set when we have a specific commit that resolved it.

Cor