Download it now!
Bug 72788 - Clear direct formatting over more paragraphs freezes LibreOffice
Summary: Clear direct formatting over more paragraphs freezes LibreOffice
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: Other Linux (All)
: medium critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: Confirmed:4.2.0.0.beta2:Ubuntu target...
Keywords: regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-12-17 12:44 UTC by Cor Nouws
Modified: 2016-06-21 21:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2013-12-17 12:44:48 UTC
to reproduce:
- new document
- type first line 'this is text' enter, second line 'more text'
- go to start of first line
- Shft-Arrow down (first paragraph selected, cursor at start of second)
- Ctrl+M (Clear direct formatting ...)

 > Writer Freezes
Comment 1 Robinson Tryon (qubit) 2013-12-17 13:20:58 UTC
TESTING on LO 4.2.0.0.beta2 + Ubuntu 12.04.3 x86_64

(In reply to comment #0)
> to reproduce:
> - new document
> - type first line 'this is text' enter, second line 'more text'
> - go to start of first line
> - Shft-Arrow down (first paragraph selected, cursor at start of second)
> - Ctrl+M (Clear direct formatting ...)
> 
>  > Writer Freezes

Following those instructions, I can't repro. Writer remains responsive; I don't even see a trace of lag when I press Ctrl+M.
Comment 2 Jorendc 2013-12-17 13:29:10 UTC
Reproducible, tested using Mac OSX 10.9 with LibreOffice Version: 4.2.0.0.beta2+
Build ID: da443ab58158d2b7ffa52742cec2be76e3aa2026
TinderBox: MacOSX-10.8@21-10.7SDK, Branch:libreoffice-4-2, Time: 2013-12-13_00:38:10

Kind regards,
Joren
Comment 3 Cor Nouws 2013-12-17 22:08:10 UTC
(In reply to comment #1)

> Following those instructions, I can't repro. Writer remains responsive; I
> don't even see a trace of lag when I press Ctrl+M.

Funny enough, it did not freeze for me too once. But I'm not able to reproduce that now ;)
(with the given instructions - I thought that when the selection did not start at the beginning of the first paragraph, the freeze did not happen).
Comment 4 Cor Nouws 2013-12-17 22:09:01 UTC
(In reply to comment #1)
> TESTING on LO 4.2.0.0.beta2 + Ubuntu 12.04.3 x86_64

Me running 4.2.0.0 beta2 on Ubuntu 13.10 32 bits..
Comment 5 Robinson Tryon (qubit) 2013-12-18 00:07:47 UTC
CONFIRMED on LO 4.2.0.0.beta2 + Ubuntu 12.04.3 x86_64

(In reply to comment #0)
> to reproduce:
> - new document
> - type first line 'this is text' enter, second line 'more text'
> - go to start of first line
> - Shft-Arrow down (first paragraph selected, cursor at start of second)

I think the phrase "first paragraph selected" was confusing to me.

If I have two lines like this:

  this is text
  more text

And then highlight from the 1st char on the 1st line down to the 1st char on the 2nd line, then pressing Ctrl+m will freeze Writer:

  [this is text
  ]more text

(perhaps unsurprisingly) if I clear direct formatting on everything first (Ctrl+a, Ctrl+m), and then make my selection as above, Ctrl+m will not freeze writer.
Comment 6 Michael Stahl (CIB) 2014-01-13 16:31:21 UTC
regression from commit c1c5feaff453cfbb23c43f2b423201b883ff048d
Comment 7 Commit Notification 2014-01-13 18:45:14 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8c59c30153b8a67d9455d70a66b4a42c35120f97

fdo#72788: sw: fix infinite loop in SwTxtAttr::RstTxtAttr



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-01-16 15:28:16 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8c6514b483edfcedb3ce546cdea726b83d418a5&h=libreoffice-4-2

fdo#72788: sw: fix infinite loop in SwTxtAttr::RstTxtAttr


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-01-16 19:59:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=134e8747e2bce391304c112e864c626680887d02&h=libreoffice-4-2-0

fdo#72788: sw: fix infinite loop in SwTxtAttr::RstTxtAttr


It will be available already in LibreOffice 4.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-06-21 21:29:14 UTC
Varun Dhall committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b252bbf9355bb4d1dad262f24ad8ceed3ac696fd

Added Test for tdf#72788 clear direct formatting

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.